summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f95be8d44c2..d43c8fdc14be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = linvst
- pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's
- pkgver = 3.2.r2.b801bdd
+ pkgdesc = Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine.
+ pkgver = 4.7.r11.141e405
pkgrel = 1
url = https://github.com/osxmidi/LinVst
arch = x86_64
license = GPL3
makedepends = git
depends = wine
- source = git+https://github.com/osxmidi/LinVst.git
- source = https://download.steinberg.net/sdk_downloads/vstsdk3611_22_10_2018_build_34.zip
+ source = linvst::git+https://github.com/osxmidi/LinVst.git
sha256sums = SKIP
- sha256sums = de64ff1b5b40a7fdc2de873e80d911ffa9fd6b82435a555dda1e8edc267d1fa3
pkgname = linvst
-
diff --git a/.gitignore b/.gitignore
index 3d592ee0e261..3472fbde951a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@ pkg/
src
*.xz
*.zip
+*.pkg.*
+linvst/
diff --git a/PKGBUILD b/PKGBUILD
index 11009264cb68..f88a28633177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
+# Maintainer: Julia DeMille <me@jdemille.com>
+# Contributor: David <ottodavid@gmx.net>
pkgname=linvst
-pkgver=3.2.r2.b801bdd
+pkgver=4.7.r11.141e405
pkgrel=1
license=('GPL3')
-pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
+pkgdesc="Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine."
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine')
makedepends=('git')
-source=('git+https://github.com/osxmidi/LinVst.git' 'https://download.steinberg.net/sdk_downloads/vstsdk3611_22_10_2018_build_34.zip')
-sha256sums=('SKIP'
- 'de64ff1b5b40a7fdc2de873e80d911ffa9fd6b82435a555dda1e8edc267d1fa3')
+source=('linvst::git+https://github.com/osxmidi/LinVst.git')
+sha256sums=('SKIP')
pkgver() {
- cd "LinVst"
- printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
-prepare() {
- ln -sf "${srcdir}/VST_SDK/VST2_SDK/pluginterfaces" "LinVst/"
+ cd "${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/LinVst"
- make -f Makefile-64-32bit DESTDIR="${pkgdir}" all
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" all
}
package() {
- cd "${srcdir}/LinVst"
- make -f Makefile-64-32bit DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
}