summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.index.json2
-rw-r--r--PKGBUILD20
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bde0fbace218..1feb8eb5947b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = llm-cli
arch = aarch64
arch = i686
arch = x86_64
- license = Apache
+ license = Apache-2.0
license = MIT
makedepends = cargo
depends = gcc-libs
diff --git a/.index.json b/.index.json
index 3569bd7e7d44..15ca3b0d1b8c 100644
--- a/.index.json
+++ b/.index.json
@@ -1,5 +1,5 @@
{
- ".i": 1,
+ ".i": 2,
"crate": "llm-cli",
"version": "0.1.1"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index a6060643266a..6378f7f05ad5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,33 @@ pkgver=0.1.1
pkgrel=1
pkgdesc='A CLI for running inference on supported Large Language Models. Powered by th...'
url='https://crates.io/crates/llm-cli'
-license=('Apache' 'MIT')
+license=('Apache-2.0' 'MIT')
depends=('gcc-libs')
makedepends=('cargo')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/llm-cli/0.1.1/download")
+source=("$_crate-0.1.1.tar.gz::https://crates.io/api/v1/crates/llm-cli/0.1.1/download")
sha512sums=('dd013d9b8f27001ed695a203b6f647e140c46bf6b7228b0c1b3d9b83abdff3e2f0060263e9cdd0ded967f7f13bdf568e1d2f2415b08679302911a894757e6a45')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
prepare() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.1.1"
- cargo fetch --locked
+ export RUSTUP_TOOLCHAIN=stable
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.1.1"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ CFLAGS+=" -ffat-lto-objects"
+
+
cargo build \
--offline \
--locked \
@@ -33,6 +41,6 @@ build() {
}
package() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.1.1"
install -Dm755 "target/release/llm" -t "$pkgdir/usr/bin"
} \ No newline at end of file