summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch54
3 files changed, 7 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fbbf49f2978..2a6961604842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 13.0.0_r384605.36d4f6d7f8ad
+ pkgver = 13.0.0_r384858.90af13447333
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -30,17 +30,14 @@ pkgbase = llvm-git
options = staticlibs
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = local://llvm-config.h
- source = local://llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
md5sums = SKIP
md5sums = 295c343dcd457dc534662f011d7cff1a
- md5sums = 5c9db72a8239005aaae0b2790c1df84f
sha512sums = SKIP
sha512sums = 75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd
- sha512sums = ffc3d1bc65c3b28ecf2b593ffbdb1bc426dd8291219b2d2e219ab458d704687293246f4a31459b1ddb50e18482884a36815a47234bb02f59fb4280cf2223d8b1
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=13.0.0_r384605.36d4f6d7f8ad-1
+ depends = llvm-libs-git=13.0.0_r384858.90af13447333-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit = LLVM Integrated Tester
@@ -78,7 +75,7 @@ pkgname = llvm-libs-git
pkgname = llvm-ocaml-git
pkgdesc = OCaml bindings for LLVM
- depends = llvm-git=13.0.0_r384605.36d4f6d7f8ad-1
+ depends = llvm-git=13.0.0_r384858.90af13447333-1
depends = ocaml
depends = ocaml-ctypes
provides = llvm-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 5530c5aecd57..655564c15eb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=13.0.0_r384605.36d4f6d7f8ad
+pkgver=13.0.0_r384858.90af13447333
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -25,15 +25,12 @@ makedepends=( 'git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'py
'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
'python-sphinx' 'python-recommonmark' 'swig' 'python' 'python-six' 'lua' 'ocl-icd' 'opencl-headers' 'z3' 'jsoncpp')
source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
- 'local://llvm-config.h'
- 'local://llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch')
+ 'local://llvm-config.h')
md5sums=('SKIP'
- '295c343dcd457dc534662f011d7cff1a'
- '5c9db72a8239005aaae0b2790c1df84f')
+ '295c343dcd457dc534662f011d7cff1a')
sha512sums=('SKIP'
- '75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd'
- 'ffc3d1bc65c3b28ecf2b593ffbdb1bc426dd8291219b2d2e219ab458d704687293246f4a31459b1ddb50e18482884a36815a47234bb02f59fb4280cf2223d8b1')
+ '75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd')
options=('staticlibs')
# NINJAFLAGS is an env var used to pass commandline options to ninja
@@ -60,11 +57,6 @@ pkgver() {
echo "$_pkgver"
}
-prepare() {
- cd llvm-project
- patch --reverse --strip=1 --input="${srcdir}/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch"
-}
-
build() {
export CFLAGS+=" ${CPPFLAGS}"
diff --git a/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch b/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
deleted file mode 100644
index 6e6797276359..000000000000
--- a/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 43ceb74eb1a5801662419fb66a6bf0d5414f1ec5 Mon Sep 17 00:00:00 2001
-From: Tom Stellard <tstellar@redhat.com>
-Date: Wed, 31 Mar 2021 21:35:04 -0700
-Subject: [PATCH] llvm-shlib: Create object libraries for each component and
- link against them
-
-This makes it possible to build libLLVM.so without first creating a
-static library for each component. In the case where only libLLVM.so is
-built (i.e. ninja LLVM) this eliminates 150 linker jobs.
-
-Reviewed By: stellaraccident
-
-Differential Revision: https://reviews.llvm.org/D95727
----
- llvm/cmake/modules/AddLLVM.cmake | 3 ++-
- llvm/tools/llvm-shlib/CMakeLists.txt | 4 ++++
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/llvm/cmake/modules/AddLLVM.cmake b/llvm/cmake/modules/AddLLVM.cmake
-index 2f055c7799624..c7a50b7a393ef 100644
---- a/llvm/cmake/modules/AddLLVM.cmake
-+++ b/llvm/cmake/modules/AddLLVM.cmake
-@@ -488,6 +488,7 @@ function(llvm_add_library name)
- add_dependencies(${obj_name} ${link_lib})
- endif()
- endforeach()
-+ target_link_libraries(${obj_name} ${ARG_LINK_LIBS})
- endif()
- endif()
-
-@@ -746,7 +747,7 @@ function(add_llvm_component_library name)
- "COMPONENT_NAME;ADD_TO_COMPONENT"
- ""
- ${ARGN})
-- add_llvm_library(${name} COMPONENT_LIB ${ARG_UNPARSED_ARGUMENTS})
-+ add_llvm_library(${name} COMPONENT_LIB OBJECT ${ARG_UNPARSED_ARGUMENTS})
- string(REGEX REPLACE "^LLVM" "" component_name ${name})
- set_property(TARGET ${name} PROPERTY LLVM_COMPONENT_NAME ${component_name})
-
-diff --git a/llvm/tools/llvm-shlib/CMakeLists.txt b/llvm/tools/llvm-shlib/CMakeLists.txt
-index b0ee19049e6fa..728995ad8b299 100644
---- a/llvm/tools/llvm-shlib/CMakeLists.txt
-+++ b/llvm/tools/llvm-shlib/CMakeLists.txt
-@@ -33,6 +33,10 @@ if(LLVM_BUILD_LLVM_DYLIB)
- add_llvm_library(LLVM SHARED DISABLE_LLVM_LINK_LLVM_DYLIB SONAME ${INSTALL_WITH_TOOLCHAIN} ${SOURCES})
-
- list(REMOVE_DUPLICATES LIB_NAMES)
-+
-+ # Link against the object libraries instead of static libraries.
-+ list(TRANSFORM LIB_NAMES PREPEND "obj.")
-+
- if(("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux") OR (MINGW) OR (HAIKU)
- OR ("${CMAKE_SYSTEM_NAME}" STREQUAL "FreeBSD")
- OR ("${CMAKE_SYSTEM_NAME}" STREQUAL "GNU")