summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e5ca62c930a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 03:27:51 UTC 2016
+pkgbase = log4cpp-rc
+ pkgdesc = A library of C++ classes for flexible logging to files, syslog, IDSA and other destinations. Release candidate version.
+ pkgver = 1.1.2rc1
+ pkgrel = 1
+ url = http://log4cpp.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ provides = log4cpp
+ conflicts = log4cpp
+ conflicts = log4cpp-git
+ source = http://downloads.sourceforge.net/log4cpp/log4cpp-1.1.2rc1.tar.gz
+ md5sums = 1f4c51703fb6cc71379e0a94900577c3
+
+pkgname = log4cpp-rc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dbcecb3e918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Applebloom <rat.o.drat@gmail.com>
+
+_pkgname="log4cpp"
+pkgname="log4cpp-rc"
+pkgver="1.1.2rc1"
+pkgrel=1
+pkgdesc="A library of C++ classes for flexible logging to files, syslog, IDSA and other destinations. Release candidate version."
+arch=('i686' 'x86_64')
+url="http://log4cpp.sourceforge.net"
+license=('LGPL')
+provides=($_pkgname)
+conflicts=($_pkgname $_pkgname-git)
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('1f4c51703fb6cc71379e0a94900577c3')
+
+build() {
+ cd "$_pkgname"
+ ./configure --prefix=/usr --disable-static --disable-doxygen \
+ --disable-dot --without-idsa
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+}