summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD21
-rw-r--r--lonote.install11
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ace1952b2aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lonote
+ pkgdesc = A free/open-source personal note-taking software which help you to editing & browsing your notes in a easy way.
+ pkgver = 3.2.12
+ pkgrel = 2
+ url = https://bitbucket.org/civalin/lonote
+ install = lonote.install
+ arch = any
+ license = apache
+ depends = python>=3.3.1
+ source = http://bitbucket.org/civalin/lonote/downloads/lonote-3.2.12.zip
+ md5sums = 5547382bc2d397f6d2cd7b61edaa6b23
+
+pkgname = lonote
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05e7a6298f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae121088b59a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Civa lin = 林雪凡 <larina.wf@gmail.com>
+# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+
+pkgname=lonote
+pkgver=3.2.12
+pkgrel=1
+pkgdesc="A free/open-source personal note-taking software which help you to editing & browsing your notes in a easy way."
+url="https://bitbucket.org/civalin/lonote"
+arch=('any')
+license=('apache')
+makedepends=('')
+depends=('python>=3.3.1')
+install=$pkgname.install
+source=(http://bitbucket.org/civalin/lonote/downloads/lonote-$pkgver.zip)
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root $pkgdir/
+ find $pkgdir -iname '*.pyc' -delete
+}
+md5sums=('5547382bc2d397f6d2cd7b61edaa6b23')
diff --git a/lonote.install b/lonote.install
new file mode 100644
index 000000000000..2c455e952b7b
--- /dev/null
+++ b/lonote.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}