summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29eaea0dbacf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lottie-qml-git
+ pkgdesc = This provides a QML Item to render Adobe® After Effects™ animations exported as JSON with Bodymovin using the Lottie Web library.
+ pkgver = r15.26335df
+ pkgrel = 1
+ url = https://github.com/kbroulik/lottie-qml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = MIT
+ makedepends = git
+ makedepends = make
+ makedepends = cmake
+ source = lottie-qml-git::git+https://github.com/kbroulik/lottie-qml.git
+ md5sums = SKIP
+
+pkgname = lottie-qml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96c2e5627751
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: ivanrajkovic
+pkgname=lottie-qml-git
+pkgver=r15.26335df
+pkgrel=1
+pkgdesc="This provides a QML Item to render Adobe® After Effects™ animations exported as JSON with Bodymovin using the Lottie Web library."
+arch=('i686' 'x86_64')
+url="https://github.com/kbroulik/lottie-qml"
+license=('GPL' 'MIT')
+makedepends=('git' 'make' 'cmake')
+source=("$pkgname"::'git+https://github.com/kbroulik/lottie-qml.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ cmake .
+ make
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+cd "$srcdir/$pkgname"
+make DESTDIR="${pkgdir}" install
+}