summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--icon.pngbin0 -> 9828 bytes
-rw-r--r--lsetwatch.desktop9
-rw-r--r--lsetwatch.sh8
5 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfb7aed1f980
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lsetwatch
+ pkgdesc = LEGO collection management software
+ pkgver = 1.20
+ pkgrel = 1
+ url = https://lebostein.de/lsetwatch/index.html
+ arch = x86_64
+ license = custom
+ depends = wine
+ source = lsetwatch-1.20.zip::https://lebostein.de/lsetwatch/builds/Lsetwatch_1.20_Windows_x64.zip
+ source = lsetwatch.sh
+ source = lsetwatch.desktop
+ source = icon.png
+ sha256sums = 1f1f633e27d563ef409a3a735710fcb0586b7346b926e9a9d4cbd3ab987c89b6
+ sha256sums = dd8ab5252c38b28cb8c8f75cc6a053c049d0c0604ddab9fb740c3cd2739c91bc
+ sha256sums = 930b1b12b6039c309aa3e3258f0b62ae8e496c67d5f7e054cce8a5d798c07131
+ sha256sums = 135ea5add0a8ffc9249e0e6ca1430992e31127f2e13757ec82fe6ed6cc73050f
+
+pkgname = lsetwatch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08557ed95e66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Frederik Leonhardt <frederik at leonhardt dot co dot nz>
+pkgname=lsetwatch
+pkgver=1.20
+pkgrel=1
+pkgdesc="LEGO collection management software"
+arch=('x86_64')
+url="https://lebostein.de/lsetwatch/index.html"
+license=('custom')
+depends=('wine')
+source=("$pkgname-$pkgver.zip::https://lebostein.de/lsetwatch/builds/Lsetwatch_${pkgver}_Windows_x64.zip"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+ "icon.png"
+)
+sha256sums=('1f1f633e27d563ef409a3a735710fcb0586b7346b926e9a9d4cbd3ab987c89b6'
+ 'dd8ab5252c38b28cb8c8f75cc6a053c049d0c0604ddab9fb740c3cd2739c91bc'
+ '930b1b12b6039c309aa3e3258f0b62ae8e496c67d5f7e054cce8a5d798c07131'
+ '135ea5add0a8ffc9249e0e6ca1430992e31127f2e13757ec82fe6ed6cc73050f')
+
+package() {
+ install -Dd "$pkgdir/usr/share/$pkgname"
+ cp -r "$srcdir/Lsetwatch"/* "$pkgdir/usr/share/$pkgname"
+
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/icon.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
+}
+
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..3052cfb0aaef
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/lsetwatch.desktop b/lsetwatch.desktop
new file mode 100644
index 000000000000..94107578ee72
--- /dev/null
+++ b/lsetwatch.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Name=Lsetwatch
+GenericName=LEGO collection management software
+Terminal=false
+Type=Application
+Exec=lsetwatch %f
+Icon=lsetwatch \ No newline at end of file
diff --git a/lsetwatch.sh b/lsetwatch.sh
new file mode 100644
index 000000000000..ce66da5282ae
--- /dev/null
+++ b/lsetwatch.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+pkgname=lsetwatch
+[ -z "$XDG_DATA_HOME" ] && XDG_DATA_HOME="$HOME/.local/share"
+export WINEPREFIX="$XDG_DATA_HOME/$pkgname"
+export WINEDLLOVERRIDES="mshtml="
+
+wine /usr/share/"$pkgname"/Lsetwatch.exe "$@"
+