summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf3191697a35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ltc-tools
+ pkgdesc = Commandline tools to deal with linear-timecode (LTC)
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/x42/ltc-tools
+ arch = x86_64
+ license = GPL2
+ depends = jack
+ depends = libltc
+ source = https://github.com/x42/ltc-tools/releases/download/v0.7.0/ltc-tools-0.7.0.tar.gz
+ sha512sums = 1e11988e81b345357ad2b51834694b4d536beddfcd534504e6e5c537b17fc845aba17f2b3aa5d0898097ad1500d1bc9e20b27188d37f806887b9c88ddf635d8b
+
+pkgname = ltc-tools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5879febf14a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: jmx <jmaibaum@gmail.com>
+
+pkgname=ltc-tools
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='Commandline tools to deal with linear-timecode (LTC)'
+arch=('x86_64')
+url="https://github.com/x42/ltc-tools"
+license=('GPL2')
+depends=('jack' 'libltc')
+source=("https://github.com/x42/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('1e11988e81b345357ad2b51834694b4d536beddfcd534504e6e5c537b17fc845aba17f2b3aa5d0898097ad1500d1bc9e20b27188d37f806887b9c88ddf635d8b')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}