summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD5
-rw-r--r--lua-magic.install14
3 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d46547b1ad7d..c366ac8a34e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Mon Dec 5 22:03:01 UTC 2016
pkgbase = lua-magic
pkgdesc = libmagic binding for lua
- pkgver = 5.25
+ pkgver = 5.41
pkgrel = 1
url = https://github.com/mah0x211/lua-magic
+ install = lua-magic.install
arch = i686
arch = x86_64
license = MIT
makedepends = lua
makedepends = lua51
makedepends = lua52
- source = lua-magic-5.25.tar.gz::https://github.com/mah0x211/lua-magic/archive/v5.25.tar.gz
- sha256sums = 98af5e79246811ddde8ba50d5b43cd4dd854f84018081aac5e25e85288565697
+ source = lua-magic-5.41.tar.gz::https://github.com/mah0x211/lua-magic/archive/v5.41.tar.gz
+ sha256sums = de1d8e3923b010ee5c8164d54afbd44bc4ff3585335439318d7230101c2eb568
pkgname = lua-magic
depends = file
@@ -25,4 +24,3 @@ pkgname = lua51-magic
pkgname = lua52-magic
depends = file
depends = lua51
-
diff --git a/PKGBUILD b/PKGBUILD
index 72ddc1ea30c1..3c3e52a33782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgbase=lua-magic
pkgname=('lua-magic' 'lua51-magic' 'lua52-magic')
-pkgver=5.25
+pkgver=5.41
pkgrel=1
pkgdesc='libmagic binding for lua'
arch=('i686' 'x86_64')
url='https://github.com/mah0x211/lua-magic'
license=('MIT')
makedepends=('lua' 'lua51' 'lua52')
+install=lua-magic.install
source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/mah0x211/${pkgbase}/archive/v${pkgver}.tar.gz")
-sha256sums=('98af5e79246811ddde8ba50d5b43cd4dd854f84018081aac5e25e85288565697')
+sha256sums=('de1d8e3923b010ee5c8164d54afbd44bc4ff3585335439318d7230101c2eb568')
build() {
cd lua-magic-${pkgver}/
diff --git a/lua-magic.install b/lua-magic.install
new file mode 100644
index 000000000000..98f7ce711b0a
--- /dev/null
+++ b/lua-magic.install
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+message() {
+ echo ":: This package has been renamed. Please install 'lua-libmagic'"
+ echo " (or 'lua51-libmagic' or 'lua52-libmagic', respectively) instead."
+}
+
+post_upgrade() {
+ message
+}
+
+post_install() {
+ message
+}