summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e42b879e5bfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lumins-bin
+ pkgdesc = A fast and reliable alternative to rsync for synchronizing local files
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/wchang22/LuminS
+ arch = x86_64
+ license = MIT
+ provides = lms
+ source = https://github.com/wchang22/LuminS/releases/download/v0.3.0/lms
+ source = LICENSE::https://raw.githubusercontent.com/wchang22/LuminS/master/LICENSE
+ md5sums = 445e0424e4ea278b5afcd0bd45d5735e
+ md5sums = b288a44ff8d3a8991c44878b97794c58
+
+pkgname = lumins-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f524478b4f06
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+
+LICENSE
+lms
+*.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dbd28211403
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kiri <kiri_so@gmail.com>
+pkgname=lumins-bin
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A fast and reliable alternative to rsync for synchronizing local files"
+arch=('x86_64')
+url="https://github.com/wchang22/LuminS"
+license=('MIT')
+provides=('lms')
+install=
+source=("https://github.com/wchang22/LuminS/releases/download/v${pkgver}/lms"
+"LICENSE::https://raw.githubusercontent.com/wchang22/LuminS/master/LICENSE")
+md5sums=('445e0424e4ea278b5afcd0bd45d5735e'
+ 'b288a44ff8d3a8991c44878b97794c58')
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/lumins-bin/LICENSE
+ install -Dm755 "$srcdir"/lms -t "$pkgdir"/usr/bin/
+}