summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a01f0a284934
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = luneta
+ pkgdesc = Interactive command-line filter that can be applied to any list, e.g., "ls | luneta"
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = https://github.com/fbeline/luneta
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = dub
+ makedepends = dmd
+ depends = ncurses
+ source = luneta-0.7.4.tar.gz::https://github.com/fbeline/luneta/archive/v0.7.4.tar.gz
+ md5sums = SKIP
+
+pkgname = luneta
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29837079d9fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+gensrcinfo.sh \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fb8aa26667a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alisa Lain <al1-ce@null.net>
+
+pkgname='luneta'
+pkgver=0.7.4
+pkgrel=1
+pkgdesc='Interactive command-line filter that can be applied to any list, e.g., "ls | luneta"'
+arch=('i686' 'x86_64')
+url='https://github.com/fbeline/luneta'
+license=('GPL')
+depends=('ncurses')
+makedepends=('dub' 'dmd')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fbeline/luneta/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ dub build -b release
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}