summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d952c8e0d706
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lustache
+ pkgdesc = Mustache templates for lua
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://olivinelabs.com/lustache/
+ arch = any
+ license = custom:MIT
+ depends = lua
+ source = https://github.com/Olivine-Labs/lustache/archive/v1.3.1-0.tar.gz
+ sha256sums = 540bd5e1f6d32aa44d5be946d1772910fb73b62fa909ca5a026c115ece4170f0
+
+pkgname = lustache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1895ad4440f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+_lua_version=5.3
+
+pkgname=lustache
+pkgver=1.3.1
+_gittag="1.3.1-0"
+pkgrel=1
+pkgdesc="Mustache templates for lua"
+arch=("any")
+url="http://olivinelabs.com/lustache/"
+license=("custom:MIT")
+depends=("lua")
+source=("https://github.com/Olivine-Labs/lustache/archive/v${_gittag}.tar.gz")
+sha256sums=('540bd5e1f6d32aa44d5be946d1772910fb73b62fa909ca5a026c115ece4170f0')
+
+package() {
+ cd "lustache-${_gittag}"
+ install -Dm644 "src/lustache.lua" "${pkgdir}/usr/share/lua/${_lua_version}/lustache.lua"
+ _files=("context" "renderer" "scanner")
+ for _file in ${_files[@]}; do
+ install -Dm644 "src/lustache/${_file}.lua" "${pkgdir}/usr/share/lua/${_lua_version}/lustache/${_file}.lua"
+ done
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/lustache/LICENSE"
+}
+