summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--rpath.patch11
3 files changed, 18 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61f808f9154b..f865f7adf139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,11 +33,13 @@ pkgbase = luxrender-hg
source = boost-15500.patch
source = luxrender-gcc7.patch
source = gcc-8.patch
+ source = rpath.patch
source = force_python3.diff
md5sums = SKIP
md5sums = b9e5c442093e69485752e6395c931b27
md5sums = fa680b0d621b42c8e7440056bf26ec1c
md5sums = 6b71588b2c3e05c8f5ddbac824a39530
+ md5sums = 53a4c379728906abb0d56ddf7152955e
md5sums = 42692e65eabc5828693e2682e94b7c64
pkgname = luxrender-hg
diff --git a/PKGBUILD b/PKGBUILD
index 381261cd9f4f..63d38337583f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,11 +22,13 @@ source=('lux::hg+https://bitbucket.org/luxrender/lux#branch=default'
'boost-15500.patch'
'luxrender-gcc7.patch'
'gcc-8.patch'
+ 'rpath.patch'
'force_python3.diff')
md5sums=('SKIP'
'b9e5c442093e69485752e6395c931b27'
'fa680b0d621b42c8e7440056bf26ec1c'
'6b71588b2c3e05c8f5ddbac824a39530'
+ '53a4c379728906abb0d56ddf7152955e'
'42692e65eabc5828693e2682e94b7c64')
pkgver() {
@@ -55,6 +57,9 @@ prepare() {
# fix unambiguous 'PyContext' both in python3.7 and lux::
sed -i 's/\&PyContext/\&lux::PyContext/g' python/pycontext.h
sed -i 's/class_<PyContext/class_<lux::PyContext/' python/pycontext.h
+
+ # fix embree2.so(embree-bvh_build-git) rpath
+ patch -Np1 -i ${srcdir}/rpath.patch
}
build() {
diff --git a/rpath.patch b/rpath.patch
new file mode 100644
index 000000000000..bbd2f47c3eb3
--- /dev/null
+++ b/rpath.patch
@@ -0,0 +1,11 @@
+diff -r f56582df55f4 CMakeLists.txt
+--- a/CMakeLists.txt Sun Jul 23 13:46:05 2017 +0200
++++ b/CMakeLists.txt Wed Nov 07 16:07:27 2018 +0100
+@@ -531,6 +531,7 @@
+ SET(LUX_LIBRARY luxShared)
+ ADD_DEFINITIONS(-DLUX_DLL) # for controlling visibility
+ SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
++ SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+ SET(CMAKE_INSTALL_RPATH "$ORIGIN")
+ ENDIF(APPLE)
+ SET(LUX_LIBRARY_DEPENDS ${LUXRAYS_LIBRARY} ${LUXCORE_LIBRARY} ${SLG_LIBRARY} ${EMBREE_LIBRARY} ${OPENCL_LIBRARIES} ${OPENGL_LIBRARY} ${FREEIMAGE_LIBRARIES} ${OPENIMAGEIO_LIBRARIES} ${OPENEXR_LIBRARIES} ${TIFF_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${Boost_LIBRARIES} ${FFTW_LIBRARIES} ${SYS_LIBRARIES})