summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--0020-logs.patch46
-rw-r--r--9999-versions.patch42
-rw-r--r--PKGBUILD48
-rwxr-xr-xlxdui.install5
5 files changed, 136 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e7ee8a23a3b..ad07130f79fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,39 @@
pkgbase = lxdui
pkgdesc = Web UI for the native Linux container technology LXD/LXC
- pkgver = 2.1.2
- pkgrel = 4
+ pkgver = 2.1.3
+ pkgrel = 1
url = https://github.com/AdaptiveScale/lxdui
install = lxdui.install
arch = x86_64
license = AGPL3
makedepends = python-virtualenv
depends = lxd
- depends = python-click
+ depends = python-flask
depends = python-netaddr
- depends = python-psutil
- depends = python-ptyprocess
- depends = python-requests
+ depends = python-pylxd
depends = python-terminado
- depends = python-tornado
provides = lxdui
+ options = !emptydirs
+ options = strip
backup = etc/lxdui/lxdui.conf
backup = etc/lxdui/log.conf
backup = etc/lxdui/auth.conf
- source = lxdui-2.1.2.tar.gz::https://github.com/AdaptiveScale/lxdui/archive/v2.1.2.tar.gz
+ source = lxdui-2.1.3.tar.gz::https://github.com/AdaptiveScale/lxdui/archive/v2.1.3.tar.gz
source = lxdui.conf
source = lxdui.sysusers
source = lxdui.tmpfiles
source = lxdui.service
source = 0010-paths.patch
- sha256sums = a9354d2f2c9fa2c3dd9e9f69407d3cda435ab86572536c518272d25dcd599ebe
+ source = 0020-logs.patch
+ source = 9999-versions.patch
+ sha256sums = 8293c4abf59e75c56941189f86fb406c5a93e62a0960d2ce7ece8da785426160
sha256sums = e419e1ecb8bec84fd676e7a729d91b48065a3a7616956bc5356e64e6d8286eac
sha256sums = b149cf164d32659b95802d0e4e455e98736de0d0ece519c48eae2eb846c35f3c
sha256sums = 4f96bb6af509e6dacf97e2298da9f2bf783f46279c6957ed288fed478206696d
sha256sums = 7487a9b77522a23b1be4c02961f46917d48b9c617d669843bbf26c4fd285d75d
sha256sums = 929c933ed0085d74972fd20c14f07b01ad4aaaff93c84897527868424447ef1f
+ sha256sums = 0bcbeb6691634026f5b0457119a18724df234189b99ca40f13f43460b61c1f40
+ sha256sums = 5fea7e09d4d21499e90f3012bddb947900b1555742b6feab93f2e858fa78532e
pkgname = lxdui
diff --git a/0020-logs.patch b/0020-logs.patch
new file mode 100644
index 000000000000..3ea9723a62e3
--- /dev/null
+++ b/0020-logs.patch
@@ -0,0 +1,46 @@
+diff -rNc lxdui-2.1.3-orig/conf/log.conf lxdui-2.1.3/conf/log.conf
+*** lxdui-2.1.3-orig/conf/log.conf 2020-05-08 20:31:30.738863778 +0200
+--- lxdui-2.1.3/conf/log.conf 2020-05-08 20:30:45.417245983 +0200
+***************
+*** 19,28 ****
+ "stream": "ext://sys.stdout"
+ },
+ "rollingFileAppender": {
+! "class": "logging.FileHandler",
+ "level": "DEBUG",
+! "formatter": "default",
+! "filename": "/var/log/lxdui/lxdui.log"
+ },
+ "file": {
+ "class": "logging.FileHandler",
+--- 19,31 ----
+ "stream": "ext://sys.stdout"
+ },
+ "rollingFileAppender": {
+! "class": "logging.handlers.RotatingFileHandler",
+ "level": "DEBUG",
+! "formatter": "expanded",
+! "filename": "/var/log/lxdui/lxdui.log",
+! "encoding": "utf-8",
+! "backupCount": 10,
+! "maxBytes": 20000000
+ },
+ "file": {
+ "class": "logging.FileHandler",
+***************
+*** 37,43 ****
+ "root": {
+ "level": "DEBUG",
+ "handlers": [
+! "file"
+ ]
+ },
+ "werkzeug":{
+--- 40,46 ----
+ "root": {
+ "level": "DEBUG",
+ "handlers": [
+! "rollingFileAppender"
+ ]
+ },
+ "werkzeug":{
diff --git a/9999-versions.patch b/9999-versions.patch
new file mode 100644
index 000000000000..68eabd7b6b5a
--- /dev/null
+++ b/9999-versions.patch
@@ -0,0 +1,42 @@
+diff -rNc lxdui-2.1.3-orig/setup.py lxdui-2.1.3/setup.py
+*** lxdui-2.1.3-orig/setup.py 2020-03-17 05:33:00.000000000 +0100
+--- lxdui-2.1.3/setup.py 2020-05-09 15:43:15.741162252 +0200
+***************
+*** 28,45 ****
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+! 'Click==6.7',
+! 'Flask==1.0',
+! 'flask-login==0.4.1',
+! 'flask_jwt==0.3.2',
+! 'jsonschema==2.6.0',
+! 'requests==2.20.0',
+! 'netaddr==0.7.19',
+! 'pyopenssl==17.5.0',
+! 'psutil==5.6.6',
+! 'pylxd==2.2.7',
+! 'terminado==0.8.1',
+! 'tornado==5.0.2',
+ 'tornado-xstatic',
+ 'XStatic==1.0.1',
+ 'XStatic-term.js==0.0.7.0'
+--- 28,45 ----
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+! 'Click==6.*',
+! 'Flask==1.*',
+! 'flask-login==0.4.*',
+! 'flask_jwt==0.3.*',
+! 'jsonschema==2.6.*',
+! 'requests==2.20.*',
+! 'netaddr==0.7.*',
+! 'pyopenssl==17.5.*',
+! 'psutil==5.6.*',
+! 'pylxd==2.2.*',
+! 'terminado==0.8.*',
+! 'tornado==5.0.*',
+ 'tornado-xstatic',
+ 'XStatic==1.0.1',
+ 'XStatic-term.js==0.0.7.0'
diff --git a/PKGBUILD b/PKGBUILD
index 11d8b9c1b58a..5349bb323a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
# Maintainer: pappy <pappy _AT_ a s c e l i o n _DOT_ com>
pkgname=lxdui
-pkgver=2.1.2
-pkgrel=4
+pkgver=2.1.3
+pkgrel=1
pkgdesc="Web UI for the native Linux container technology LXD/LXC"
arch=(x86_64)
url="https://github.com/AdaptiveScale/lxdui"
license=('AGPL3')
depends=(lxd
- python-click
+# python-click
+ python-flask
+# python-flask-login
+# python-flask-jwt
+# python-idna
+# python-jsonschema
python-netaddr
- python-psutil
- python-ptyprocess
- python-requests
+# python-pyopenssl
+# python-psutil
+ python-pylxd
+# python-requests
python-terminado
- python-tornado
-
+# python-tornado
+# python-tornado-xstatic
+# python-urllib3
+# python-xstatic
+# python-xstatic-term.js
)
makedepends=('python-virtualenv')
provides=(lxdui)
@@ -31,18 +40,24 @@ source=($pkgname-$pkgver.tar.gz::https://github.com/AdaptiveScale/$pkgname/archi
$pkgname.service
0010-paths.patch
+ 0020-logs.patch
+ 9999-versions.patch
)
-sha256sums=('a9354d2f2c9fa2c3dd9e9f69407d3cda435ab86572536c518272d25dcd599ebe'
+sha256sums=('8293c4abf59e75c56941189f86fb406c5a93e62a0960d2ce7ece8da785426160'
'e419e1ecb8bec84fd676e7a729d91b48065a3a7616956bc5356e64e6d8286eac'
'b149cf164d32659b95802d0e4e455e98736de0d0ece519c48eae2eb846c35f3c'
'4f96bb6af509e6dacf97e2298da9f2bf783f46279c6957ed288fed478206696d'
'7487a9b77522a23b1be4c02961f46917d48b9c617d669843bbf26c4fd285d75d'
- '929c933ed0085d74972fd20c14f07b01ad4aaaff93c84897527868424447ef1f')
+ '929c933ed0085d74972fd20c14f07b01ad4aaaff93c84897527868424447ef1f'
+ '0bcbeb6691634026f5b0457119a18724df234189b99ca40f13f43460b61c1f40'
+ '5fea7e09d4d21499e90f3012bddb947900b1555742b6feab93f2e858fa78532e')
+options=(!emptydirs strip)
prepare()
{
- cd $pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
+
for s in ${source[@]}; do
case $s in
*.patch)
@@ -52,21 +67,23 @@ prepare()
;;
esac
done
+
+ sed -i "/^VERSION/ s:=.*:= '${pkgver}':" app/__metadata__.py
}
-package() {
+package()
+{
virtualenv --system-site-packages $pkgdir/usr/lib/$pkgname
- pushd $pkgname-$pkgver
+ pushd $srcdir/$pkgname-$pkgver
$pkgdir/usr/lib/$pkgname/bin/python setup.py install --optimize=1
$pkgdir/usr/lib/$pkgname/bin/pip uninstall -y pip setuptools wheel
popd
+ find $pkgdir/usr/lib/$pkgname/lib -type d \( -name testsuite -o -name tests -o -name __pycache__ \) -exec rm -rf {} \; 2>/dev/null || true
find $pkgdir/usr/lib/$pkgname/bin -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;
- find $pkgdir/usr/lib/$pkgname/lib -type d \( -name testsuite -o -name tests \) -exec rm -rf {} \; 2>/dev/null || true
install -dm755 $pkgdir/usr/bin
-
ln -s ../lib/$pkgname/bin/lxdui $pkgdir/usr/bin/lxdui
install -Dm644 $pkgname.conf $pkgdir/etc/$pkgname/$pkgname.conf
@@ -76,6 +93,7 @@ package() {
PYVER=$($pkgdir/usr/lib/$pkgname/bin/python --version|cut -d\ -f2|cut -d. -f1,2)
+# mv $pkgdir/usr/lib/$pkgname/lib/python$PYVER/site-packages/conf/* $pkgdir/etc/$pkgname
mv $pkgdir/usr/lib/$pkgname/lib/python$PYVER/site-packages/LXDUI-$pkgver-py$PYVER.egg/conf/* $pkgdir/etc/$pkgname
chmod 600 $pkgdir/etc/$pkgname/auth.conf
}
diff --git a/lxdui.install b/lxdui.install
index 331814309189..1cf835961868 100755
--- a/lxdui.install
+++ b/lxdui.install
@@ -19,12 +19,13 @@ EOF
post_upgrade()
{
+ find /usr/lib/lxdui/lib -name __pycache__ -exec rm -rf {} \; 2>/dev/null
systemctl daemon-reload
}
pre_remove()
{
- systemctl stop lxdui
- systemctl disable lxdui
+ systemctl disable --now lxdui
+ find /usr/lib/lxdui/lib -name __pycache__ -exec rm -rf {} \; 2>/dev/null
}