summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c30f432f00a..5c83d1234d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = lyricsources
makedepends = git
makedepends = meson
depends = python2-dbus
- depends = python2-gobject
+ depends = python2-gobject2
depends = python2-pycurl
source = https://github.com/naaando/lyricsources/archive/0.1/lyricsources-0.1.tar.gz
sha256sums = 363407184541762121a954d1d96265d86510906a38662f4f5113e5c5bc4405e7
diff --git a/PKGBUILD b/PKGBUILD
index 8bc411835dea..d979dce5eae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,16 @@ pkgdesc="Lyric downloader dbus service from osdlyrics"
arch=(any)
url="https://github.com/naaando/lyricsources"
license=(GPL3)
-depends=(python2-dbus python2-gobject python2-pycurl)
+depends=(python2-dbus python2-gobject2 python2-pycurl)
makedepends=(git meson)
source=(https://github.com/naaando/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz)
sha256sums=('363407184541762121a954d1d96265d86510906a38662f4f5113e5c5bc4405e7')
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i 's/dist-packages/site-packages/' meson.build
+}
+
build() {
arch-meson $pkgname-$pkgver build
meson compile -C build