summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32f3a348e778..e151791f5bff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,11 @@ pkgbase = lyvi
optdepends = python-dbus: mpris support
optdepends = python-gobject: mpris support
source = https://github.com/ok100/lyvi/archive/v2.0.0.tar.gz
+ source = https://github.com/ok100/lyvi/commit/b84176c9c440bd627943e0d25831fa98c2a9c1f7.patch
+ source = https://github.com/ok100/lyvi/commit/6777afe89ca1f680f1e5f73ac95fe33295a5ce3b.patch
md5sums = 8c85fc43b8f7f225fd4231801762a6bb
+ md5sums = eac8d51f7bd209efa7699ed38bd914b5
+ md5sums = 2d4dd00ecd4f36acdbac8022577873c2
pkgname = lyvi
diff --git a/PKGBUILD b/PKGBUILD
index 4a5a45985620..72e48db7553d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,20 @@ depends=('python-glyr' 'python-pillow' 'python-psutil' 'python-urwid')
optdepends=('python-dbus: mpris support'
'python-gobject: mpris support')
makedepends=('python-pip')
-source=("https://github.com/ok100/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('8c85fc43b8f7f225fd4231801762a6bb')
+source=("https://github.com/ok100/${pkgname}/archive/v${pkgver}.tar.gz"
+ "https://github.com/ok100/${pkgname}/commit/b84176c9c440bd627943e0d25831fa98c2a9c1f7.patch"
+ "https://github.com/ok100/${pkgname}/commit/6777afe89ca1f680f1e5f73ac95fe33295a5ce3b.patch"
+)
+md5sums=('8c85fc43b8f7f225fd4231801762a6bb'
+ 'eac8d51f7bd209efa7699ed38bd914b5'
+ '2d4dd00ecd4f36acdbac8022577873c2'
+)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ${srcdir}/b84176c9c440bd627943e0d25831fa98c2a9c1f7.patch
+ patch -p1 -i ${srcdir}/6777afe89ca1f680f1e5f73ac95fe33295a5ce3b.patch
+}
package() {
cd "$srcdir/$pkgname-$pkgver"