summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD34
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..834c3367d360
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = m3d-print
+ pkgdesc = Print 3D objects on your M3D Micro
+ pkgver = 1.5.0.70
+ pkgrel = 1
+ url = http://www.printm3d.com/
+ arch = x86_64
+ license = custom
+ depends = mono
+ provides = m3d-print
+ source = https://printm3d.com/files/software/linux/M3D-Linux-1.5.0.70.tar.gz
+ source = https://printm3d.com/files/software/linux/README-1.5.0.70.pdf
+ md5sums = b0b9537726ed30b00e167a1350ba6566
+ md5sums = 9ae06dff9bb2865841f9d5cac39fddc2
+
+pkgname = m3d-print
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a638319ebbcc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pdf
+*.tar.gz
+*.tar.xz
+
+pkg/
+src/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caad8cde4f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Marco Feltmann <coding@marcofeltmann.de>
+
+pkgname=m3d-print
+pkgrel=1
+pkgver=1.5.0.70
+pkgdesc="Print 3D objects on your M3D Micro"
+url="http://www.printm3d.com/"
+provides=('m3d-print')
+arch=('x86_64')
+license=('custom')
+depends=('mono')
+makedepends=()
+backup=()
+install=''
+source=(
+ "https://printm3d.com/files/software/linux/M3D-Linux-${pkgver}.tar.gz"
+ "https://printm3d.com/files/software/linux/README-${pkgver}.pdf"
+)
+md5sums=(
+ 'b0b9537726ed30b00e167a1350ba6566'
+ '9ae06dff9bb2865841f9d5cac39fddc2'
+)
+
+package() {
+ install -d "$pkgdir"/opt
+ cp -R "$srcdir"/M3D.App "$pkgdir"/opt/M3D.App
+ cp -R "$srcdir/README-$pkgver.pdf" "$pkgdir"/opt/M3D.App/README.pdf
+
+ install -d "$pkgdir"/usr/bin
+ echo "#!/bin/sh\nmono /opt/M3D.App/M3DGUI 2>&1 1>/dev/null &" > "$pkgdir"/usr/bin/m3d-print
+ chmod 755 "$pkgdir"/usr/bin/m3d-print
+
+ echo "If this is your first installation of the app or the M3D on this computer please refer to the readme at /opt/M3D.App/README.pdf for system setup instructions."
+}