summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD24
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d31b91d377f..1f9ee8dbe394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = mango
pkgdesc = A tool for making backups of Arch packages and their dependencies
- pkgver = 1.4.3
+ pkgver = 2.0.1
pkgrel = 1
url = https://gitlab.com/Taro94/mango
arch = any
license = GPL
- makedepends = dotnet-sdk-3.1
+ makedepends = dotnet-sdk>=6
depends = tar
+ depends = pacman
options = !strip
- source = https://gitlab.com/Taro94/mango/-/archive/1.4.3/mango-1.4.3.tar.gz
- md5sums = ca47e93b557b6b4173e54bd585303dae
+ source = https://gitlab.com/Taro94/mango/-/archive/2.0.1/mango-2.0.1.tar.gz
+ md5sums = f95a3fc5d28b886ae449ffc06cd21e01
pkgname = mango
diff --git a/PKGBUILD b/PKGBUILD
index 97f16d0e6209..da07252d6fbc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Stanisław Jasiewicz <stjasiewicz@gmail.com>
+# Maintainer: Stanisław Jasiewicz <stjasiewicz@protonmail.com>
pkgname=mango
-pkgver=1.4.3
+pkgver=2.0.1
pkgrel=1
pkgdesc="A tool for making backups of Arch packages and their dependencies"
arch=('any')
url="https://gitlab.com/Taro94/mango"
license=('GPL')
-depends=('tar')
-makedepends=('dotnet-sdk-3.1')
+depends=('tar' 'pacman')
+makedepends=('dotnet-sdk>=6')
source=("https://gitlab.com/Taro94/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('ca47e93b557b6b4173e54bd585303dae')
+md5sums=('f95a3fc5d28b886ae449ffc06cd21e01')
options=(!strip)
+build() {
+ cd "$pkgname-$pkgver/Mango"
+ dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -p:PublishReadyToRun=true -o published
+ mv published/Mango published/mango
+}
+
package() {
- cd "$pkgname-$pkgver"
- dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -o published
- install -Dm 755 "published/${pkgname}" -t "$pkgdir/usr/bin"
- install -Dm 755 "mango/fakepkg.sh" -t "$pkgdir/usr/share/mango"
+ cd "$pkgname-$pkgver/Mango"
+ ls
+ install -Dm 755 "published/mango" -t "$pkgdir/usr/bin"
+ install -Dm 755 "published/fakepkg.sh" -t "$pkgdir/usr/share/mango"
}