summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bcb47348988..3a8226af4d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = markdown-link-check
pkgdesc = Checks aliveness of hyperlinks in markdown documents
- pkgver = 3.12.1
+ pkgver = 3.12.2
pkgrel = 1
url = https://github.com/tcort/markdown-link-check
arch = any
license = ISC
makedepends = npm
depends = nodejs
- noextract = markdown-link-check-3.12.1.tgz
- source = https://registry.npmjs.org/markdown-link-check/-/markdown-link-check-3.12.1.tgz
- sha256sums = 2aa792b9d43ee3300eb605126e891099f3da8ab38485894a6661d31efcf12f01
+ noextract = markdown-link-check-3.12.2.tgz
+ source = https://registry.npmjs.org/markdown-link-check/-/markdown-link-check-3.12.2.tgz
+ sha256sums = 8cb9c0a70f368f976f2b6ea8b641c209124d18c1311244b45b13202188800cbf
pkgname = markdown-link-check
diff --git a/PKGBUILD b/PKGBUILD
index f632aa6d0b29..c0c803b40d04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Maintainer: Carl Smedstad <carsme@archlinux.org>
pkgname=markdown-link-check
-pkgver=3.12.1
+pkgver=3.12.2
pkgrel=1
pkgdesc="Checks aliveness of hyperlinks in markdown documents"
arch=(any)
@@ -11,7 +11,7 @@ depends=(nodejs)
makedepends=(npm)
source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha256sums=('2aa792b9d43ee3300eb605126e891099f3da8ab38485894a6661d31efcf12f01')
+sha256sums=('8cb9c0a70f368f976f2b6ea8b641c209124d18c1311244b45b13202188800cbf')
package() {
npm install --global \
@@ -25,4 +25,7 @@ package() {
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396
chown -R root:root "$pkgdir"
+
+ # Remove man pages to silence namcap warnings
+ rm -r "$pkgdir/usr/lib/node_modules/markdown-link-check/node_modules/marked/man"
}