summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--matcher-git.patch21
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfcb89985ba0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = matcher-git
+ pkgdesc = Intelligently searches through a list of file names for the one you were probably looking for.
+ pkgver = 1.0.0.r0.g6c54c26
+ pkgrel = 1
+ url = https://github.com/burke/matcher
+ arch = i686
+ arch = x86_64
+ license = BSD2
+ makedepends = git
+ provides = matcher
+ conflicts = matcher
+ source = git+https://github.com/burke/matcher
+ source = matcher-git.patch
+ md5sums = SKIP
+ md5sums = f96518bab54f9dd6b404bb7378a52b07
+
+pkgname = matcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58a456055f49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: awe00 < awe00 AT hotmail DOT fr>
+pkgname=matcher-git
+pkgver=1.0.0.r0.g6c54c26
+pkgrel=1
+pkgdesc="Intelligently searches through a list of file names for the one you were probably looking for."
+arch=('i686' 'x86_64')
+url="https://github.com/burke/matcher"
+license=('BSD2')
+makedepends=('git')
+provides=('matcher')
+conflicts=('matcher')
+source=("git+https://github.com/burke/matcher" "matcher-git.patch")
+md5sums=('SKIP' 'f96518bab54f9dd6b404bb7378a52b07')
+_gitrepo=matcher
+
+pkgver() {
+ cd "$_gitrepo"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_gitrepo"
+ patch -p1 <../matcher-git.patch
+}
+
+build() {
+ cd "$_gitrepo"
+ make
+}
+
+package() {
+ cd "$_gitrepo"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/matcher-git.patch b/matcher-git.patch
new file mode 100644
index 000000000000..8b7472f6e1a1
--- /dev/null
+++ b/matcher-git.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 437f372..126dac8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ EXENAME=matcher
+-PREFIX=/usr/local
+-BINDIR=$(PREFIX)/bin
++PREFIX=/usr
++BINDIR=$(PREFIX)/bin/
+
+ .PHONY: all
+ all: $(EXENAME)
+@@ -10,5 +10,5 @@ $(EXENAME): main.c matcher.c
+
+ .PHONY: install
+ install: $(EXENAME)
+- install -d $(DESTDIR)$(PREFIX)
+- install -m 0755 $< $(DESTDIR)$(PREFIX)/bin
++ install -d $(DESTDIR)$(BINDIR)
++ install -m 0755 $< $(DESTDIR)$(BINDIR)