summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 235b2520eaaa..96d28c7a1553 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = materia-custom-accent
pkgdesc = Easy installer for the materia theme with a custom accent color, gdm and qt5 support (edit PKGBUILD)
- pkgver = r1607.68baf805
+ pkgver = 20210322
pkgrel = 1
url = https://github.com/nana-4/materia-theme
arch = any
license = GPL
- makedepends = bc
makedepends = sassc
makedepends = inkscape
depends = gtk3>=3.22
@@ -15,11 +14,11 @@ pkgbase = materia-custom-accent
optdepends = kvantum-qt5: qt5 theme support
conflicts = materia-theme
conflicts = kvantum-theme-materia
- source = materia-theme::git+https://github.com/nana-4/materia-theme.git
- source = materia-theme-qt::git+https://github.com/PapirusDevelopmentTeam/materia-kde.git
+ source = materia-theme-20210322.tar.gz::https://github.com/nana-4/materia-theme/archive/refs/tags/v20210322.tar.gz
+ source = materia-theme-20210307-qt.tar.gz::https://github.com/PapirusDevelopmentTeam/materia-kde/archive/refs/tags/20210307.tar.gz
source = 99-gdm-use-materia-theme.hook
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 4460af612cd70242543ac71023f8963eea39be059486e9ebe58b3846be74bcb5
+ sha256sums = 0474c94e2db944f3efffbcba651289d2ddf11dcaffc0dabf6e1042a254ed9ea1
sha256sums = 7db390763b37c3cc2c2984a8a3e8452d1822ac579def6a07eecbee076fb73d77
pkgname = materia-custom-accent
diff --git a/PKGBUILD b/PKGBUILD
index 4fe129949dc7..8b2ee9479b02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,9 @@ _colors_dark="SEL_BG=$_accent FG=eeeeee \n BG=212121 \n HDR_FG=e0e0e0 \n HDR_BG=
pkgdesc="Easy installer for the materia theme with a custom accent color, gdm and qt5 support (edit PKGBUILD)"
arch=('any')
url="https://github.com/nana-4/materia-theme"
+pkgver=20210322
_url_qt="https://github.com/PapirusDevelopmentTeam/materia-kde"
-pkgver=r1607.68baf805
+_pkgver_qt=20210307
pkgrel=1
license=('GPL')
makedepends=(sassc inkscape)
@@ -20,16 +21,12 @@ optdepends=(
provides=()
conflicts=('materia-theme' 'kvantum-theme-materia')
replaces=()
-source=(${_pkgname}::git+$url.git
- ${_pkgname}-qt::git+$_url_qt.git
+source=("${_pkgname}-${pkgver}.tar.gz"::"${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ "${_pkgname}-${_pkgver_qt}-qt.tar.gz"::"${_url_qt}/archive/refs/tags/${_pkgver_qt}.tar.gz"
99-gdm-use-materia-theme.hook)
-sha256sums=('SKIP'
- 'SKIP'
+sha256sums=('4460af612cd70242543ac71023f8963eea39be059486e9ebe58b3846be74bcb5'
+ '0474c94e2db944f3efffbcba651289d2ddf11dcaffc0dabf6e1042a254ed9ea1'
'7db390763b37c3cc2c2984a8a3e8452d1822ac579def6a07eecbee076fb73d77')
-pkgver() {
- cd "${srcdir}/${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
prepare(){
# materia-qt has no ./change_color script