summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD115
2 files changed, 16 insertions, 151 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43509117a489..0e909f57f2c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,51 +1,11 @@
pkgbase = matrix-mirage-git
- pkgdesc = A fancy, customizable, keyboard-operable Matrix chat client for encrypted and decentralized communication.
- pkgver = 0.7.2.r0.g9a4ababd
- pkgrel = 2
- url = https://github.com/mirukana/mirage
- arch = x86_64
- license = LGPL3
- makedepends = cmake
- makedepends = git
- depends = hicolor-icon-theme
- depends = libxss
- depends = qt5-base
- depends = qt5-declarative
- depends = qt5-quickcontrols2
- depends = python-hsluv
- depends = python-matrix-nio
- depends = python-pymediainfo
- depends = python-pyotherside
- depends = python-sortedcontainers
- depends = python-watchgod
- depends = dbus-python
- depends = python-appdirs
- depends = python-async_generator
- depends = python-cairosvg
- depends = python-filetype
- depends = python-hsluv
- depends = python-lxml
- depends = python-pillow
- depends = python-html-sanitizer
- depends = python-mistune1
- depends = python-plyer
- depends = python-redbaron
- depends = python-simpleaudio
- provides = mirage-matrix
+ pkgdesc = metapackage - migrate to moment-git
+ pkgver = 0.0.1
+ pkgrel = 1
+ epoch = 1
+ arch = any
provides = matrix-mirage
- conflicts = mirage-matrix
conflicts = matrix-mirage
- source = matrix-mirage::git+https://github.com/mirukana/mirage
- source = RadialBarDemo::git+https://github.com/mirukana/RadialBarDemo
- source = SortFilterProxyModel::git+https://github.com/oKcerG/SortFilterProxyModel
- source = gel::git+https://github.com/Cutehacks/gel
- source = hsluv-c::git+https://github.com/hsluv/hsluv-c
- source = qsyncable::git+https://github.com/benlau/qsyncable
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = matrix-mirage-git
+ depends = moment-git
diff --git a/PKGBUILD b/PKGBUILD
index b7716ee39fd0..556315a41191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,112 +1,17 @@
# Maintainer:
-# Contributor: Midov <midov@midov.pl>
-_pkgname="matrix-mirage"
+_newpkg='moment-git'
+_pkgname='matrix-mirage'
pkgname="$_pkgname-git"
-pkgver=0.7.2.r0.g9a4ababd
-pkgrel=2
-pkgdesc='A fancy, customizable, keyboard-operable Matrix chat client for encrypted and decentralized communication.'
-arch=('x86_64')
-url='https://github.com/mirukana/mirage'
-license=('LGPL3')
+pkgver=0.0.1
+pkgrel=1
+epoch=1
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
-depends=(
- 'hicolor-icon-theme'
- 'libxss'
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quickcontrols2'
-
- # Runtime
- 'python-hsluv'
- 'python-matrix-nio'
- # 'python-aiofiles'
- 'python-pymediainfo'
- 'python-pyotherside'
- 'python-sortedcontainers'
- 'python-watchgod'
-
- 'dbus-python'
- 'python-appdirs'
- 'python-async_generator'
- 'python-cairosvg'
- 'python-filetype'
- 'python-hsluv'
- 'python-lxml'
- 'python-pillow'
-
- # AUR
- 'python-html-sanitizer'
- 'python-mistune1'
- 'python-plyer'
- # 'python-pyfastcopy'
- 'python-redbaron'
- # 'python-baron'
- # 'python-rply'
- 'python-simpleaudio'
-)
-
-makedepends=(
- 'cmake'
- 'git'
-)
-
-provides=(
- 'mirage-matrix'
- 'matrix-mirage'
-)
-conflicts=(${provides[@]})
-
-source=(
- "$_pkgname"::"git+$url"
-
- 'RadialBarDemo'::'git+https://github.com/mirukana/RadialBarDemo'
- 'SortFilterProxyModel'::'git+https://github.com/oKcerG/SortFilterProxyModel'
- 'gel'::'git+https://github.com/Cutehacks/gel'
- 'hsluv-c'::'git+https://github.com/hsluv/hsluv-c'
- 'qsyncable'::'git+https://github.com/benlau/qsyncable'
-)
-sha256sums=(
- 'SKIP'
-
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
-
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$srcdir/$_pkgname"
- _submodules=(
- 'submodules/RadialBarDemo'
- 'submodules/SortFilterProxyModel'
- 'submodules/gel'
- 'submodules/hsluv-c'
- 'submodules/qsyncable'
- )
- for submodule in ${_submodules[@]} ; do
- mkdir -p "$submodule"
- git submodule init ${submodule}
- git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
- git -c protocol.file.allow=always submodule update ${submodule}
- done
-
- sed -Ei 's@collections\.Mapping@collections.abc.Mapping@g' "$srcdir/$_pkgname/src/backend/utils.py"
-}
-
-build() {
- cd "$srcdir/$_pkgname"
- qmake PREFIX=/usr mirage.pro
- make
-}
+conflicts=("$_pkgname")
+provides=("$_pkgname")
package() {
- cd "$srcdir/$_pkgname"
- make INSTALL_ROOT="$pkgdir" install
+ depends=("$_newpkg")
}