summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20682b6892cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = matrix.sh
+ pkgdesc = Bash script to send messages to a matrix chat.
+ pkgver = 1.4
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/fabianonline/matrix.sh
+ arch = x86_64
+ license = GPL3
+ source = matrix.sh::https://raw.githubusercontent.com/fabianonline/matrix.sh/master/matrix.sh
+ sha256sums = 9307d677ece2c82bceb59cf33d1edc18024b512b6f5458e63a7b57e3710ad5ef
+
+pkgname = matrix.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd6e81b0c9fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel Poellmann <aur@<lastname><firstname>.de>
+
+pkgname=matrix.sh
+epoch=1
+pkgver=1.4
+pkgrel=1
+pkgdesc='Bash script to send messages to a matrix chat.'
+arch=('x86_64')
+url='https://github.com/fabianonline/matrix.sh'
+license=('GPL3')
+depends=()
+makedepends=()
+source=("matrix.sh::https://raw.githubusercontent.com/fabianonline/matrix.sh/master/matrix.sh")
+sha256sums=('9307d677ece2c82bceb59cf33d1edc18024b512b6f5458e63a7b57e3710ad5ef')
+options=()
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ install -Dm644 "$srcdir/matrix.sh" "$pkgdir/usr/bin/matrix.sh"
+ chmod +x "$pkgdir/usr/bin/matrix.sh"
+}