summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36e69a8d0918..db37d88b9161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,14 @@
pkgbase = maui-clip-git
pkgdesc = Video player and video collection manager
- pkgver = r98.1d1c5aa
+ pkgver = v1.1.1.r1.g909383b
pkgrel = 1
url = https://invent.kde.org/maui/clip
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
groups = maui-apps
license = GPL3
makedepends = git
@@ -16,6 +21,7 @@ pkgbase = maui-clip-git
depends = attica
depends = ki18n
depends = kcoreaddons
+ depends = mpv
provides = cinema
provides = maui-clip
conflicts = cinema
diff --git a/PKGBUILD b/PKGBUILD
index f8ead3bf76a4..c94894dee1a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=maui-clip-git
-pkgver=r98.1d1c5aa
+pkgver=v1.1.1.r1.g909383b
pkgrel=1
pkgdesc="Video player and video collection manager"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
groups=('maui-apps')
url="https://invent.kde.org/maui/clip"
license=('GPL3')
-depends=('kio' 'mauikit-git' 'mauikit-filebrowsing-git' 'attica' 'ki18n' 'kcoreaddons')
+depends=('kio' 'mauikit-git' 'mauikit-filebrowsing-git' 'attica' 'ki18n' 'kcoreaddons' 'mpv')
makedepends=('git' 'extra-cmake-modules' 'qt5-tools' 'qt5-svg')
provides=('cinema' 'maui-clip')
conflicts=('cinema' 'cinema-git' 'maui-clip')
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S clip
- cmake --build build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S clip
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file