summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
3 files changed, 66 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a25d2e345dad
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = menuconfig-git
+ pkgdesc = Standalone version of the mconf tool from the linux kernel
+ pkgver = r17.0a95e19
+ pkgrel = 1
+ url = https://github.com/TheGeorge/menuconfig
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = ncurses
+ source = git://github.com/TheGeorge/menuconfig.git
+
+pkgname = menuconfig-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..074969a49a00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = menuconfig-git
+ pkgdesc = Standalone version of the mconf tool from the linux kernel
+ pkgver = r17.0a95e19
+ pkgrel = 1
+ url = https://github.com/TheGeorge/menuconfig
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = ncurses
+ source = git://github.com/TheGeorge/menuconfig.git
+ sha1sums = SKIP
+
+pkgname = menuconfig-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56977e37f93b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=menuconfig-git
+pkgver=r17.0a95e19
+pkgrel=1
+pkgdesc='Standalone version of the mconf tool from the linux kernel'
+url='https://github.com/TheGeorge/menuconfig'
+arch=(i686 x86_64)
+license=(GPL2)
+depends=(ncurses)
+makedepends=(git cmake)
+source=(git://github.com/TheGeorge/menuconfig.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd menuconfig
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd menuconfig
+ sed -e 's|ncursesw/curses.h|curses.h|' -i lxdialog/dialog.h
+}
+
+build() {
+ cd menuconfig
+ cmake .
+ make
+}
+
+package() {
+ cd menuconfig
+ install -m755 -d "$pkgdir/usr/bin"
+ install -m755 -t "$pkgdir/usr/bin" conf mconf
+}