summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f40edcf2607..260687558a48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mercurial-stable-hg
pkgdesc = Distributed source control management tool (development stable branch)
- pkgver = r50369.558d08dc7dd4
+ pkgver = r50865.0a4efb650b3e
pkgrel = 1
url = https://www.mercurial-scm.org/
arch = i686
@@ -12,7 +12,7 @@ pkgbase = mercurial-stable-hg
depends = glibc
depends = python
optdepends = tk: for the hgk GUI
- provides = mercurial=r50369.558d08dc7dd4
+ provides = mercurial=r50865.0a4efb650b3e
conflicts = mercurial
backup = etc/mercurial/hgrc
source = hg+https://www.mercurial-scm.org/repo/hg#branch=stable
diff --git a/PKGBUILD b/PKGBUILD
index cdaabf3ad80d..a3ba3a4f54e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=mercurial-stable-hg
-pkgver=r50369.558d08dc7dd4
+pkgver=r50865.0a4efb650b3e
pkgrel=1
pkgdesc="Distributed source control management tool (development stable branch)"
arch=('i686' 'x86_64')
@@ -22,7 +22,9 @@ sha256sums=('SKIP'
pkgver() {
cd "hg"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ _rev=$(hg identify -n)
+ _hash=$(hg identify -i)
+ printf "r%s.%s" "$_rev" "$_hash"
}
build() {