summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD33
4 files changed, 30 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7418e39aa4c0..379dd23eca77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = merge-request-notifier
pkgdesc = This app shows your merge requests grouped by projects and WIP status. It is accessible from the system tray.
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/codecentric/merge-request-notifier
arch = x86_64
license = MIT
- source = https://github.com/codecentric/merge-request-notifier/releases/download/v1.7.0/merge-request-notifier-1.7.0.tar.xz
- source = https://raw.githubusercontent.com/codecentric/merge-request-notifier/master/build/icon.png
+ makedepends = nodejs
+ makedepends = yarn
+ source = git+https://github.com/codecentric/merge-request-notifier.git
source = merge-request-notifier.desktop
- sha256sums = bd1827f0e65826859fae1b49f04ec292c86e1ed2b2f829b247e08aa6f231ddbf
- sha256sums = 1b852a6efc5d806a73a7ea8ca0fc39f066da95063716ab53c564820860fe9fc0
+ sha256sums = SKIP
sha256sums = 8d74ce91de6352aeb82d7d81ddafc8b730ce831804f55fa724de2174095d0ce6
pkgname = merge-request-notifier
diff --git a/.gitignore b/.gitignore
index 1851207a6bc9..ae53909de2d1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,3 @@
!PKGBUILD
!.SRCINFO
!*.desktop
-!LICENSE
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index d6626ddf6b21..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2019 codecentric AG
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index e1eaa3bbf0c2..17cac2072ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,49 @@
pkgname=merge-request-notifier
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="This app shows your merge requests grouped by projects and WIP status. It is accessible from the system tray."
arch=('x86_64')
license=('MIT')
+makedepends=('nodejs' 'yarn')
url='https://github.com/codecentric/merge-request-notifier'
-source=("https://github.com/codecentric/merge-request-notifier/releases/download/v${pkgver}/merge-request-notifier-${pkgver}.tar.xz"
- "https://raw.githubusercontent.com/codecentric/merge-request-notifier/master/build/icon.png"
+source=("git+https://github.com/codecentric/merge-request-notifier.git"
"merge-request-notifier.desktop")
-sha256sums=('bd1827f0e65826859fae1b49f04ec292c86e1ed2b2f829b247e08aa6f231ddbf'
- '1b852a6efc5d806a73a7ea8ca0fc39f066da95063716ab53c564820860fe9fc0'
+sha256sums=('SKIP'
'8d74ce91de6352aeb82d7d81ddafc8b730ce831804f55fa724de2174095d0ce6')
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout v${pkgver}
+}
+
package() {
+ # Install desktop entry
install -Dm644 merge-request-notifier.desktop "${pkgdir}/usr/share/applications/merge-request-notifier.desktop"
- cd "${srcdir}"
+ # Go to source files
+ cd "${srcdir}/${pkgname}"
+
+ # Prepare directory structure
mkdir -p "${pkgdir}/opt/merge-request-notifier"
mkdir -p "${pkgdir}/usr/bin"
- install -Dm644 icon.png "${pkgdir}/usr/share/icons/hicolor/0x0/apps/merge-request-notifier.png"
- cp -R merge-request-notifier-1.7.0/* "${pkgdir}/opt/merge-request-notifier"
+ # Build application
+ yarn install
+ yarn build
+ yarn package --dir
+
+ # Copy build artifacts to package
+ cp -R release/linux-unpacked/* "${pkgdir}/opt/merge-request-notifier"
+ # Link binary so that it is executable from $PATH
ln -sf /opt/merge-request-notifier/merge-request-notifier "${pkgdir}/usr/bin/merge-request-notifier"
+ # Install icon and license
+ install -Dm644 build/icon.png "${pkgdir}/usr/share/icons/hicolor/0x0/apps/merge-request-notifier.png"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Fix permissions
chmod -R go-w "${pkgdir}"
}