summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch15
3 files changed, 6 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af326088c526..cdf3e257c9bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, stripped down git version
- pkgver = 22.2.0_devel.153440.ad864a7c150
- pkgrel = 2
+ pkgver = 22.2.0_devel.153457.718070f0e7b
+ pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
license = custom
@@ -42,13 +42,10 @@ pkgbase = mesa-minimal-git
conflicts = mesa-vdpau
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
- source = workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = a4e1e8a8a90b6434b80d8ec859747e0c
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806
pkgname = mesa-minimal-git
depends = libdrm
diff --git a/PKGBUILD b/PKGBUILD
index a51dc9ce1091..654b1d873ed8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgname=mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=22.2.0_devel.153440.ad864a7c150
-pkgrel=2
+pkgver=22.2.0_devel.153457.718070f0e7b
+pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto' 'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
'wayland-protocols' 'meson' 'ninja' 'glslang' 'llvm-minimal-git' 'libdrm' 'libclc')
@@ -26,14 +26,11 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
- 'workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch'
)
md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a'
- 'a4e1e8a8a90b6434b80d8ec859747e0c')
+ '5c65a0fe315dd347e09b1f2826a1df5a')
sha512sums=('SKIP'
- '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806')
+ '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
# ninja grabs all available cores and leaves almost nothing for other processes.
# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
@@ -52,9 +49,6 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
-
- # see https://gitlab.freedesktop.org/mesa/mesa/-/issues/6359
- patch --directory="mesa" --forward --strip=1 --input="${srcdir}/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch"
}
build () {
diff --git a/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch b/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
deleted file mode 100644
index 597eff7bc707..000000000000
--- a/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
+++ /dev/null
@@ -1,15 +0,0 @@
----
- src/gallium/auxiliary/gallivm/lp_bld.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/src/gallium/auxiliary/gallivm/lp_bld.h
-+++ b/src/gallium/auxiliary/gallivm/lp_bld.h
-@@ -81,7 +81,7 @@
- #define LLVMInsertBasicBlock ILLEGAL_LLVM_FUNCTION
- #define LLVMCreateBuilder ILLEGAL_LLVM_FUNCTION
-
--#if LLVM_VERSION_MAJOR >= 8
-+#if LLVM_VERSION_MAJOR >= 8 && LLVM_VERSION_MAJOR < 15
- #define GALLIVM_HAVE_CORO 1
- #else
- #define GALLIVM_HAVE_CORO 0