summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--import_bundle_out.patch37
3 files changed, 0 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cf43075f166..cefa60914b6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -39,7 +39,6 @@ pkgbase = meshlab-git
source = meshlabserver_GLU.patch
source = mpir.patch
source = rpath.patch
- source = import_bundle_out.patch
source = qt5.11.patch
source = meshlab.desktop
sha256sums = SKIP
@@ -54,7 +53,6 @@ pkgbase = meshlab-git
sha256sums = 5a041c414777036ebd8925108a9bb51f66ab435324ff4671012bdcb806fcf400
sha256sums = 865b318f4196b1a34b17867dc18e116ef5f702b4905bb2d536609eb79af1c1bc
sha256sums = c43cb14de251f369734330e1f93744f71527360e1894c93e9f9f8abe686db050
- sha256sums = b3a72caff34d3c05840298bc7b758061dc353b662e1bb526dfb5463fa2a7cd18
sha256sums = 2236863292bf078b2e89d278bad834fd08563613d40e33ec471ae92588132a57
sha256sums = 030ab1dcafb7d793bed3bc455497208addadf1091a4619576fe7e044aed4231a
diff --git a/PKGBUILD b/PKGBUILD
index 3443a853ea70..a29518711b73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,6 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git"
"meshlabserver_GLU.patch"
"mpir.patch"
"rpath.patch"
- "import_bundle_out.patch"
"qt5.11.patch"
"meshlab.desktop")
sha256sums=('SKIP'
@@ -44,7 +43,6 @@ sha256sums=('SKIP'
'5a041c414777036ebd8925108a9bb51f66ab435324ff4671012bdcb806fcf400'
'865b318f4196b1a34b17867dc18e116ef5f702b4905bb2d536609eb79af1c1bc'
'c43cb14de251f369734330e1f93744f71527360e1894c93e9f9f8abe686db050'
- 'b3a72caff34d3c05840298bc7b758061dc353b662e1bb526dfb5463fa2a7cd18'
'2236863292bf078b2e89d278bad834fd08563613d40e33ec471ae92588132a57'
'030ab1dcafb7d793bed3bc455497208addadf1091a4619576fe7e044aed4231a')
@@ -83,8 +81,6 @@ prepare() {
msg "fix muparser unicode string"
patch -Np1 -i ../muparser_drop_unicode.patch
cd ${srcdir}/vcglib
- msg "fix import bundler/nvm"
- patch -Np1 -i ../import_bundle_out.patch
}
build() {
diff --git a/import_bundle_out.patch b/import_bundle_out.patch
deleted file mode 100644
index 0afa53584e64..000000000000
--- a/import_bundle_out.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/wrap/io_trimesh/import_nvm.h b/wrap/io_trimesh/import_nvm.h
-index c9e8fe22..e5e46507 100644
---- a/wrap/io_trimesh/import_nvm.h
-+++ b/wrap/io_trimesh/import_nvm.h
-@@ -85,13 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams){
- return true;
- }
-
--static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
-- FILE *fp = fopen(filename, "r");
-- if(!fp) return false;
-- ReadHeader(fp);
-- fclose(fp);
-- return true;
--}
-
-
- static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
-diff --git a/wrap/io_trimesh/import_out.h b/wrap/io_trimesh/import_out.h
-index 01331bc5..c2cd86fe 100644
---- a/wrap/io_trimesh/import_out.h
-+++ b/wrap/io_trimesh/import_out.h
-@@ -85,14 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams, unsigned int &num_points
- return true;
- }
-
--static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
-- FILE *fp = fopen(filename, "r");
-- if(!fp) return false;
-- ReadHeader(fp);
-- fclose(fp);
-- return true;
--}
--
-
- static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
- std::vector<std::string > & image_filenames,