summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--pyside_property_error.patch42
3 files changed, 3 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de4990e3a3d6..70fe90280d8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meshroom-git
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
- pkgver = 2021.1.0.r134.gf1331c6a
+ pkgver = 2021.1.0.r630.g8e9128be
pkgrel = 1
url = https://alicevision.github.io/
arch = i686
@@ -32,11 +32,9 @@ pkgbase = meshroom-git
source = voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git
source = git+https://github.com/alicevision/QtOIIO.git#branch=develop
source = git+https://github.com/alicevision/qmlAlembic.git#branch=develop
- source = pyside_property_error.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc
pkgname = meshroom-git
diff --git a/PKGBUILD b/PKGBUILD
index f971bc6164b4..88c2ac5325dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ name=meshroom
fragment="#branch=develop"
components+=(QtOIIO qmlAlembic)
pkgname=${name}-git
-pkgver=2021.1.0.r134.gf1331c6a
+pkgver=2021.1.0.r630.g8e9128be
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
@@ -32,13 +32,11 @@ source=("${name}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git#branch=develop"
"git+https://github.com/alicevision/qmlAlembic.git#branch=develop"
- "pyside_property_error.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
+ 'SKIP')
((ENABLE_QTALICEVISION)) && {
source+=("git+https://github.com/alicevision/qtAliceVision.git#branch=develop")
sha256sums+=('SKIP')
@@ -69,9 +67,6 @@ prepare() {
sed -i '/find_package(IlmBase REQUIRED)/d' "${srcdir}"/qmlAlembic/CMakeLists.txt
sed -i 's|${ILMBASE_INCLUDE_DIR}||' "${srcdir}"/qmlAlembic/src/CMakeLists.txt
rm -rf "${srcdir}"/qmlAlembic/cmake/
-
- # avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
- patch -Np1 -i "$srcdir"/pyside_property_error.patch
}
build() {
diff --git a/pyside_property_error.patch b/pyside_property_error.patch
deleted file mode 100644
index 0423594d0764..000000000000
--- a/pyside_property_error.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- meshroom.orig/meshroom/ui/app.py 2021-03-01 16:44:31.268547600 +0000
-+++ meshroom/meshroom/ui/app.py 2021-03-01 16:49:33.466725600 +0000
-@@ -284,7 +284,6 @@
- return md
- return markdown(md)
-
-- @Property(QJsonValue, constant=True)
- def systemInfo(self):
- import platform
- import sys
-@@ -292,8 +291,8 @@
- 'platform': '{} {}'.format(platform.system(), platform.release()),
- 'python': 'Python {}'.format(sys.version.split(" ")[0])
- }
-+ systemInfo = Property(QJsonValue, fget=systemInfo, constant=True)
-
-- @Property("QVariantList", constant=True)
- def licensesModel(self):
- """
- Get info about open-source licenses for the application.
-@@ -315,6 +314,7 @@
- "onlineUrl": "https://raw.githubusercontent.com/alicevision/AliceVision/develop/COPYING.md"
- }
- ]
-+ licensesModel = Property("QVariantList", fget=licensesModel, constant=True)
-
- recentProjectFilesChanged = Signal()
- recentProjectFiles = Property("QVariantList", _recentProjectFiles, notify=recentProjectFilesChanged)
---- meshroom.orig/meshroom/ui/reconstruction.py 2021-03-01 16:44:31.313764800 +0000
-+++ meshroom/meshroom/ui/reconstruction.py 2021-03-01 16:50:33.238323700 +0000
-@@ -249,10 +249,10 @@
- self._undistortedImagePath = os.path.join(self._activeNode_PrepareDenseScene.node.output.value, filename)
- self.denseSceneParamsChanged.emit()
-
-- @Property(type=QObject, constant=True)
- def attribute(self):
- """ Get the underlying Viewpoint attribute wrapped by this Viewpoint. """
- return self._viewpoint
-+ attribute = Property(QObject, fget=attribute, constant=True)
-
- @Property(type="QVariant", notify=initialParamsChanged)
- def initialIntrinsics(self):