summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d3494f35d9..901392b37e37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = micro
pkgdesc = A modern and intuitive terminal-based text editor
pkgver = 2.0.8
- pkgrel = 1
- url = https://github.com/zyedidia/micro
+ pkgrel = 2
+ url = https://micro-editor.github.io/
arch = aarch64
arch = armv6h
arch = armv7h
@@ -13,6 +13,7 @@ pkgbase = micro
makedepends = go
depends = glibc
optdepends = xclip: Required for copying/pasting text
+ optdepends = wl-clipboard
source = micro-2.0.8::git+https://github.com/zyedidia/micro.git#tag=v2.0.8
source = semver::git+https://github.com/blang/semver
source = go-humanize::git+https://github.com/dustin/go-humanize
diff --git a/PKGBUILD b/PKGBUILD
index f8ac9ca4150c..ddc38ab16285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,17 @@
pkgname=micro
pkgver=2.0.8
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and intuitive terminal-based text editor"
arch=("aarch64" "armv6h" "armv7h" "i686" "x86_64")
-url="https://github.com/zyedidia/${pkgname}"
+url="https://${pkgname}-editor.github.io/"
license=("MIT")
depends=("glibc")
makedepends=("git" "go")
-optdepends=("xclip: Required for copying/pasting text")
+optdepends=(
+ "xclip: Required for copying/pasting text"
+ "wl-clipboard"
+)
source=(
"${pkgname}-${pkgver}::git+https://github.com/zyedidia/${pkgname}.git#tag=v${pkgver}"
"semver::git+https://github.com/blang/semver"
@@ -92,8 +95,8 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -x -v"
- make build-quick
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw -x -v"
+ make build
# To avoid issues deleting directories next time
go clean --modcache