summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49f29a31e412
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = midimon
+ pkgdesc = Basic MIDI monitor, works w/ JACK or ALSA MIDI drivers
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://midimon.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libglademm
+ depends = lash
+ source = http://downloads.sourceforge.net/midimon/midimon-0.3.tar.gz
+ md5sums = dcfd9d135768438f67fab0322a2636f4
+
+pkgname = midimon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..280ccd0671e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: masutu <masutu dot arch at googlemail dot com>
+# Maintainer: masutu <masutu dot arch at googlemail dot com>
+
+pkgname=midimon
+pkgver=0.3
+pkgrel=1
+pkgdesc="Basic MIDI monitor, works w/ JACK or ALSA MIDI drivers"
+arch=('i686' 'x86_64')
+url="http://midimon.sourceforge.net/"
+license=('GPL')
+depends=('libglademm' 'lash')
+source=(http://downloads.sourceforge.net/midimon/$pkgname-$pkgver.tar.gz)
+md5sums=('dcfd9d135768438f67fab0322a2636f4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ sed -i 28i\#include\ \<stdio.h\> src/mm_lash.cc
+ sed -i 27i\#include\ \<stdio.h\> src/mm_signal.cc
+ sed -i 's/\/doc\/midimon/\/share\/doc\/midimon/' Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
+
+