summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xminecraft2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc3f1b8ca27b..a469a5177665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Nov 30 08:46:33 UTC 2017
+# Thu Nov 30 08:55:43 UTC 2017
pkgbase = minecraft
pkgdesc = An open-world game whose gameplay revolves around breaking and placing blocks
pkgver = latest
- pkgrel = 27
+ pkgrel = 28
url = http://www.minecraft.net/
install = minecraft.install
arch = any
license = custom
- depends = jre8-openjdk
+ depends = java-runtime=8
depends = xorg-xrandr
depends = ttf-font
depends = libxtst
@@ -19,7 +19,7 @@ pkgbase = minecraft
source = minecraft.png
source = minecraft.install
source = LICENSE
- md5sums = 45a068cb13e31824c941ceb3851630e5
+ md5sums = 34440b7ad94c02762b9cbf78c7a1e23e
md5sums = 85273e24404cc6865805f951487b8a1e
md5sums = ecb1bd9b6e6305987b6fb5832ab0b468
md5sums = dfecf76f9db4497399f4b7c171150c89
diff --git a/PKGBUILD b/PKGBUILD
index 3d1e30297dfd..92b2dabb9d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# CVS for PKGBUILD is available at https://github.com/christopherobin/pkgbuilds/tree/master/minecraft
pkgname=minecraft
pkgver=latest
-pkgrel=27
+pkgrel=28
pkgdesc="An open-world game whose gameplay revolves around breaking and placing blocks"
arch=(any)
license=('custom')
url="http://www.minecraft.net/"
-depends=('jre8-openjdk' 'xorg-xrandr' 'ttf-font' 'libxtst')
+depends=('java-runtime=8' 'xorg-xrandr' 'ttf-font' 'libxtst')
noextract=('minecraft.jar')
source=(minecraft http://s3.amazonaws.com/Minecraft.Download/launcher/Minecraft.jar
minecraft.desktop minecraft.png minecraft.install LICENSE)
-md5sums=('45a068cb13e31824c941ceb3851630e5'
+md5sums=('34440b7ad94c02762b9cbf78c7a1e23e'
'85273e24404cc6865805f951487b8a1e'
'ecb1bd9b6e6305987b6fb5832ab0b468'
'dfecf76f9db4497399f4b7c171150c89'
diff --git a/minecraft b/minecraft
index 8b437347f388..b10c5f9b3277 100755
--- a/minecraft
+++ b/minecraft
@@ -1,7 +1,7 @@
#!/bin/sh
# We need to force Java 8 here since both Java 7 and 9 currently causes the game to crash
-export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
+export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:/usr/lib/jvm/java-8-jre/jre/bin/:$PATH
# Since launching the minecraft launch from the home directory bypass the update mechanism, I'm adding this
# small piece of code that will do a checksum of the versions.json file provided by mojang, if a new version