summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042d2fdf09d3..fe5f60e05395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = minecraft-c
pkgdesc = Minecraft Classic 0.0.30a reimplemented in C.
- pkgver = 1.0
+ pkgver = 1.2
pkgrel = 1
url = https://github.com/johnpayne-dev/MinecraftC
arch = x86_64
@@ -8,11 +8,14 @@ pkgbase = minecraft-c
makedepends = git
makedepends = clang
depends = sdl2
- source = minecraft-c::git+https://github.com/johnpayne-dev/MinecraftC
+ depends = stb
+ source = https://github.com/johnpayne-dev/MinecraftC/archive/43928d42e1f32bd76a994f0bb22c0153a7271b3f.zip
+ source = https://raw.githubusercontent.com/johnpayne-dev/cute_headers/master/cute_sound.h
source = minecraft-c.desktop
source = minecraft-c.png
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = minecraft-c
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 24c935a21579..d62b6d85e431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: ROllerozxa (temporaryemail4meh [gee mail])
pkgname=minecraft-c
-pkgver=1.0
+pkgver=1.2
+_pkghash=43928d42e1f32bd76a994f0bb22c0153a7271b3f
pkgrel=1
pkgdesc="Minecraft Classic 0.0.30a reimplemented in C."
arch=(x86_64)
url="https://github.com/johnpayne-dev/MinecraftC"
license=('MIT')
-depends=('sdl2')
+depends=('sdl2' 'stb')
makedepends=('git' 'clang')
-source=("${pkgname}::git+https://github.com/johnpayne-dev/MinecraftC"
+source=("${url}/archive/${_pkghash}.zip"
+ "https://raw.githubusercontent.com/johnpayne-dev/cute_headers/master/cute_sound.h"
"${pkgname}.desktop"
"${pkgname}.png")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
build() {
- cd "${pkgname}"
+ cd "MinecraftC-${_pkghash}"
+
+ cp ../cute_sound.h External/cute_headers/
# Building
mkdir -p Output
@@ -30,13 +34,17 @@ build() {
MinecraftC/Player/*.c \
MinecraftC/Render/*.c \
MinecraftC/Render/Texture/*.c \
+ MinecraftC/Sound/*.c \
MinecraftC/Utilities/*.c \
- -lm -lSDL2 -lGL -lGLU \
+ -lm -lSDL2 -lGL -lGLU -O2 \
+ -I"/usr/include/SDL2/" \
+ -I"/usr/include/stb/" \
+ -I"External/cute_headers/" \
-o Output/MinecraftC
}
package() {
- install -Dm755 "${srcdir}/${pkgname}/Output/MinecraftC" "${pkgdir}/usr/bin/MinecraftC"
+ install -Dm755 "${srcdir}/MinecraftC-${_pkghash}/Output/MinecraftC" "${pkgdir}/usr/bin/MinecraftC"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}