summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--Minestein.zipbin0 -> 180842 bytes
-rwxr-xr-xPKGBUILD33
-rw-r--r--minestein.desktop10
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccf271ab3b84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = minestein
+ pkgdesc = A version of the famous Minesweeper game which will always produce puzzles that can be solved using logic.
+ pkgver = 1
+ pkgrel = 10
+ url = http://sourgumdrop.org.uk/minestein_1.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = glibc
+ depends = python2
+ depends = tk
+ source = Minestein.zip
+ source = minestein.desktop
+ md5sums = 636769163002a521bcf884bd40bc7e73
+ md5sums = 3a01e2b1acba45e4404a80f6eeac7e89
+
+pkgname = minestein
+
diff --git a/Minestein.zip b/Minestein.zip
new file mode 100644
index 000000000000..7c52722daeda
--- /dev/null
+++ b/Minestein.zip
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..77b91f66785e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Eric Forgeot < http://anamnese.online.fr >
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=minestein
+pkgver=1
+pkgrel=10
+pkgdesc="A version of the famous Minesweeper game which will always produce puzzles that can be solved using logic."
+arch=('i686' 'x86_64')
+url="http://sourgumdrop.org.uk/minestein_1.html"
+license=('GPL')
+depends=('glibc' 'python2' 'tk' )
+makedepends=('unzip')
+# Home page expired, I include the source directly into the package for the time being:
+#source=("http://sourgumdrop.org.uk/pad/Minestein.zip" "$pkgname.desktop")
+source=("Minestein.zip" "$pkgname.desktop")
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/{bin,share/minestein}
+ install -D -m644 \
+ Minestein_icon.ico \
+ Minestein_pad_file.xml \
+ Minestein.pyw \
+ "$pkgdir/usr/share/minestein"
+ echo -e "#!/bin/sh\npython2 /usr/share/minestein/Minestein.pyw" > "$pkgdir/usr/bin/minestein"
+ chmod 755 "$pkgdir/usr/bin/minestein"
+
+ install -D -m644 "$srcdir/Minestein_icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -D -m644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+md5sums=('636769163002a521bcf884bd40bc7e73'
+ '3a01e2b1acba45e4404a80f6eeac7e89')
diff --git a/minestein.desktop b/minestein.desktop
new file mode 100644
index 000000000000..636d3c0eddff
--- /dev/null
+++ b/minestein.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Minestein
+GenericName=Minestein
+Comment=A version of the famous Minesweeper game which will always produce puzzles that can be solved using logic
+Icon=minestein.png
+Exec=minestein
+Categories=Game;LogicGame