summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--minetest-mod-stargate-git.install26
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb4eef5db9fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = minetest-mod-stargate-git
+ pkgdesc = StarGate SF series inspired travel network.
+ pkgver = 11.b8bd9cf
+ pkgrel = 1
+ url = https://github.com/minetest-mods/stargate
+ install = minetest-mod-stargate-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ optdepends = minetest-usrdir_patch
+ provides = minetest-mod-stargate
+ source = minetest-mod-stargate::git://github.com/minetest-mods/stargate.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-stargate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7144e3552ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: nano thirteen <nano13@gmx.net>
+
+pkgname=minetest-mod-stargate-git
+_gitname=${pkgname%-git*}
+pkgver=11.b8bd9cf
+pkgrel=1
+pkgdesc="StarGate SF series inspired travel network. "
+arch=('any')
+url="https://github.com/minetest-mods/stargate"
+license=('custom')
+depends=()
+optdepends=('minetest-usrdir_patch')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git://github.com/minetest-mods/stargate.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-stargate-git.install b/minetest-mod-stargate-git.install
new file mode 100644
index 000000000000..7488efec6056
--- /dev/null
+++ b/minetest-mod-stargate-git.install
@@ -0,0 +1,26 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods on Linux. This is disabled by default though and thus'
+ echo ' needs patching to work.'
+ echo ' You can install "minetest-usrdir_patch" which will enable this path. If'
+ echo ' you dont the mods will not be recognized and selactable in Minetest.'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods on Linux. This is disabled by default though and thus'
+ echo ' needs patching to work.'
+ echo ' You can install "minetest-usrdir_patch" which will enable this path. If'
+ echo ' you dont the mods will not be recognized and selactable in Minetest.'
+ echo
+ echo
+}