summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1b9613a15e3..3de2c2292422 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-abseil-cpp
pkgdesc = Collection of C++ library code designed to augment the C++ standard library (mingw-w64)
- pkgver = 20230802.1
+ pkgver = 20240116.1
pkgrel = 1
url = https://abseil.io
arch = any
@@ -10,7 +10,7 @@ pkgbase = mingw-w64-abseil-cpp
options = !buildflags
options = !strip
options = staticlibs
- source = https://github.com/abseil/abseil-cpp/archive/20230802.1/abseil-cpp-20230802.1.tar.gz
- sha256sums = 987ce98f02eefbaf930d6e38ab16aa05737234d7afbab2d5c4ea7adbe50c28ed
+ source = https://github.com/abseil/abseil-cpp/archive/20240116.1/abseil-cpp-20240116.1.tar.gz
+ sha256sums = 3c743204df78366ad2eaf236d6631d83f6bc928d1705dd0000b872e53b73dc6a
pkgname = mingw-w64-abseil-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 90119ef34f06..d6e7aa4ffcdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-abseil-cpp
-pkgver=20230802.1
+pkgver=20240116.1
pkgrel=1
pkgdesc='Collection of C++ library code designed to augment the C++ standard library (mingw-w64)'
arch=('any')
@@ -9,18 +9,15 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
source=("https://github.com/abseil/abseil-cpp/archive/$pkgver/abseil-cpp-$pkgver.tar.gz")
-sha256sums=('987ce98f02eefbaf930d6e38ab16aa05737234d7afbab2d5c4ea7adbe50c28ed')
+sha256sums=('3c743204df78366ad2eaf236d6631d83f6bc928d1705dd0000b872e53b73dc6a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/abseil-cpp-$pkgver"
- # add ABSL_FORCE_WAITER_MODE=4 for https://github.com/abseil/abseil-cpp/issues/1510
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- CXXFLAGS="-DABSL_FORCE_WAITER_MODE=4" ${_arch}-cmake ..
- make
- popd
+ ${_arch}-cmake -B build-${_arch} .
+ make -C build-${_arch}
done
}