summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0003-libpsl-static-libs.patch39
-rw-r--r--PKGBUILD7
3 files changed, 5 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80a9c8d090a8..fad85aaf78e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-curl
pkgdesc = An URL retrival utility and library (mingw-w64)
- pkgver = 8.6.0
+ pkgver = 8.7.1
pkgrel = 1
url = https://curl.haxx.se
arch = any
@@ -18,13 +18,11 @@ pkgbase = mingw-w64-curl
options = staticlibs
options = !strip
options = !buildflags
- source = https://curl.haxx.se/download/curl-8.6.0.tar.xz
+ source = https://curl.haxx.se/download/curl-8.7.1.tar.xz
source = 0002-nghttp2-static.patch
- source = 0003-libpsl-static-libs.patch
source = 0004-more-static-fixes.patch
- sha256sums = 3ccd55d91af9516539df80625f818c734dc6f2ecf9bada33c76765e99121db15
+ sha256sums = 6fea2aac6a4610fbd0400afb0bcddbe7258a64c63f1f68e5855ebc0c659710cd
sha256sums = 3ee9c75a3046f86f91290c143170179230c9adc6eabfbb79eb26f708a165b719
- sha256sums = 79aa3b1d1a6d943341d9c7f9ce69b46a5f454bf9fedaf5530b0cbcefa65fa31e
sha256sums = 590eb65e90e756eaad993d52a101f29091ada2c742c5a607684e88fc5c560d54
pkgname = mingw-w64-curl
diff --git a/0003-libpsl-static-libs.patch b/0003-libpsl-static-libs.patch
deleted file mode 100644
index 71e7efd5e115..000000000000
--- a/0003-libpsl-static-libs.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- curl-8.6.0/configure.ac.orig 2024-01-31 08:31:51.163839600 +0100
-+++ curl-8.6.0/configure.ac 2024-01-31 08:33:39.021970100 +0100
-@@ -2059,12 +2059,30 @@
- with_libpsl=yes)
- curl_psl_msg="no (libpsl disabled)"
- if test $with_libpsl != "no"; then
-- AC_SEARCH_LIBS(psl_builtin, psl,
-- [curl_psl_msg="enabled";
-- AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-- ],
-- [AC_MSG_ERROR([libpsl was not found]) ]
-- )
-+ CURL_CHECK_PKGCONFIG(libpsl)
-+ if test "$PKGCONFIG" != "no" ; then
-+ LIB_PSL=`$PKGCONFIG --libs-only-l libpsl`
-+ LD_PSL=`$PKGCONFIG --libs-only-L libpsl`
-+ CPP_PSL=`$PKGCONFIG --cflags-only-I libpsl`
-+ version=`$PKGCONFIG --modversion libpsl`
-+ DIR_PSL=`echo $LD_PSL | $SED -e 's/-L//'`
-+
-+ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-+ LDFLAGS="$LDFLAGS $LD_PSL"
-+ CPPFLAGS="$CPPFLAGS $CPP_PSL"
-+ LIBS="$LIB_PSL $LIBS"
-+ else
-+ dnl no nghttp2 pkg-config found, deal with it
-+ AC_SEARCH_LIBS(psl_builtin, psl,
-+ [curl_psl_msg="yes";
-+ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-+ ],
-+ [curl_psl_msg="no (libpsl not found)";
-+ AC_MSG_WARN([libpsl was not found])
-+ ]
-+ )
-+ fi
-+
- fi
- AM_CONDITIONAL([USE_LIBPSL], [test "$curl_psl_msg" = "enabled"])
-
diff --git a/PKGBUILD b/PKGBUILD
index a202ed726e53..2bd95431b0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ant32 <antreimer at gmail dot com>
pkgname=mingw-w64-curl
-pkgver=8.6.0
+pkgver=8.7.1
pkgrel=1
pkgdesc="An URL retrival utility and library (mingw-w64)"
arch=('any')
@@ -22,11 +22,9 @@ makedepends=('mingw-w64-configure')
options=('staticlibs' '!strip' '!buildflags')
source=("${url}/download/curl-${pkgver}.tar.xz"
"0002-nghttp2-static.patch"
- "0003-libpsl-static-libs.patch"
"0004-more-static-fixes.patch")
-sha256sums=('3ccd55d91af9516539df80625f818c734dc6f2ecf9bada33c76765e99121db15'
+sha256sums=('6fea2aac6a4610fbd0400afb0bcddbe7258a64c63f1f68e5855ebc0c659710cd'
'3ee9c75a3046f86f91290c143170179230c9adc6eabfbb79eb26f708a165b719'
- '79aa3b1d1a6d943341d9c7f9ce69b46a5f454bf9fedaf5530b0cbcefa65fa31e'
'590eb65e90e756eaad993d52a101f29091ada2c742c5a607684e88fc5c560d54')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -34,7 +32,6 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}
patch -Np1 -i "${srcdir}/0002-nghttp2-static.patch"
- patch -Np1 -i "${srcdir}/0003-libpsl-static-libs.patch"
patch -Np1 -i "${srcdir}/0004-more-static-fixes.patch"
autoreconf -vfi
}