summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-format-security-error.patch12
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9be9efe066df..b71dc8ac1925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,10 +12,12 @@ pkgbase = mingw-w64-libbs2b
options = staticlibs
source = https://downloads.sourceforge.net/sourceforge/bs2b/libbs2b-3.1.0.tar.gz
source = fix-dll-no-undefined.patch
+ source = fix-format-security-error.patch
md5sums = 2c3351f1785364107aabc44f67d33d84
md5sums = 032add726f4355682a09b34fcb610328
+ md5sums = 6158826339a7082348195eaa0c205756
sha1sums = a71318211611a00bd3d595b0830d2188938ff89d
sha1sums = a8f643592e2851e25dda19ecf33f39f5132668a1
+ sha1sums = 8c6ea1d38789107cc9b1a71dd5eb24864ad50341
pkgname = mingw-w64-libbs2b
-
diff --git a/PKGBUILD b/PKGBUILD
index 4e6ea209a022..0cfcdea36dad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,17 +12,21 @@ depends=('mingw-w64-libsndfile')
makedepends=('mingw-w64-configure')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://downloads.sourceforge.net/sourceforge/bs2b/${_pkgname}-${pkgver}.tar.gz"
- "fix-dll-no-undefined.patch")
+ "fix-dll-no-undefined.patch"
+ "fix-format-security-error.patch")
md5sums=('2c3351f1785364107aabc44f67d33d84'
- '032add726f4355682a09b34fcb610328')
+ '032add726f4355682a09b34fcb610328'
+ '6158826339a7082348195eaa0c205756')
sha1sums=('a71318211611a00bd3d595b0830d2188938ff89d'
- 'a8f643592e2851e25dda19ecf33f39f5132668a1')
+ 'a8f643592e2851e25dda19ecf33f39f5132668a1'
+ '8c6ea1d38789107cc9b1a71dd5eb24864ad50341')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/fix-dll-no-undefined.patch"
+ patch -Np1 -i "${srcdir}/fix-format-security-error.patch"
autoreconf -fiv
}
diff --git a/fix-format-security-error.patch b/fix-format-security-error.patch
new file mode 100644
index 000000000000..2909e045c35d
--- /dev/null
+++ b/fix-format-security-error.patch
@@ -0,0 +1,12 @@
+diff -durN libbs2b-3.1.0.orig/src/bs2bconvert.c libbs2b-3.1.0/src/bs2bconvert.c
+--- libbs2b-3.1.0.orig/src/bs2bconvert.c 2009-06-05 02:01:15.000000000 +0800
++++ libbs2b-3.1.0/src/bs2bconvert.c 2021-09-11 17:53:23.535750900 +0800
+@@ -153,7 +153,7 @@
+ if( ( infile = sf_open( infilename, SFM_READ, &sfinfo ) ) == NULL )
+ {
+ printf( "Not able to open input file %s.\n", infilename );
+- printf( sf_strerror( NULL ) );
++ printf( "%s", sf_strerror( NULL ) );
+ return 1;
+ }
+