summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 7 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0fad486f7e7..e2a282b70ca8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = mingw-w64-python-wheel
arch = any
license = MIT
makedepends = mingw-w64-python-setuptools
- makedepends = mingw-w64-python2-setuptools
makedepends = fakeroot
makedepends = lib32-fakeroot
depends = wine
@@ -16,8 +15,3 @@ pkgbase = mingw-w64-python-wheel
pkgname = mingw-w64-python-wheel
depends = mingw-w64-python
optdepends = mingw-w64-python-keyring: for wheel.signatures
-
-pkgname = mingw-w64-python2-wheel
- depends = mingw-w64-python2
- optdepends = mingw-w64-python2-keyring: for wheel.signatures
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 255e5b07ea40..afa12aabb9ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pypiname=wheel
pkgbase=mingw-w64-python-wheel
-pkgname=('mingw-w64-python-wheel' 'mingw-w64-python2-wheel')
+pkgname=('mingw-w64-python-wheel')
pkgver=0.30.0
pkgrel=2
pkgdesc="A built-package format for Python (mingw-w64)"
arch=(any)
url="https://pypi.python.org/pypi/wheel"
license=('MIT')
-makedepends=('mingw-w64-python-setuptools' 'mingw-w64-python2-setuptools' 'fakeroot' 'lib32-fakeroot')
+makedepends=('mingw-w64-python-setuptools' 'fakeroot' 'lib32-fakeroot')
depends=('wine')
source=("https://github.com/pypa/${_pypiname}/archive/${pkgver}.tar.gz")
md5sums=('a7341e955a3563e806abd44efabad9cb')
@@ -17,45 +17,26 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
mkdir "${srcdir}/python3-build-i686-w64-mingw32"
- mkdir "${srcdir}/python2-build-i686-w64-mingw32"
mkdir "${srcdir}/python3-build-x86_64-w64-mingw32"
- mkdir "${srcdir}/python2-build-x86_64-w64-mingw32"
-
+
cp -R ${srcdir}/${_pypiname}-${pkgver}/. "${srcdir}/python3-build-i686-w64-mingw32"
- cp -R ${srcdir}/${_pypiname}-${pkgver}/. "${srcdir}/python2-build-i686-w64-mingw32"
cp -R ${srcdir}/${_pypiname}-${pkgver}/. "${srcdir}/python3-build-x86_64-w64-mingw32"
- cp -R ${srcdir}/${_pypiname}-${pkgver}/. "${srcdir}/python2-build-x86_64-w64-mingw32"
}
build() {
for _arch in ${_architectures}; do
cd "${srcdir}/python3-build-${_arch}"
wine /usr/${_arch}/bin/python3.exe setup.py build
- cd "${srcdir}/python2-build-${_arch}"
- wine /usr/${_arch}/bin/python2.exe setup.py build
done
}
package_mingw-w64-python-wheel() {
depends=('mingw-w64-python')
optdepends=('mingw-w64-python-keyring: for wheel.signatures')
-
- for _arch in ${_architectures}; do
- cd "${srcdir}/python3-build-${_arch}"
- /usr/${_arch}/bin/python3.exe setup.py install --root="$pkgdir/" --prefix=\usr/${_arch} --optimize=1
- install -D -m644 LICENSE.txt "${pkgdir}/usr/${_arch}/share/licenses/${pkgname}/LICENSE.txt"
- done
-}
-package_mingw-w64-python2-wheel() {
- depends=('mingw-w64-python2')
- optdepends=('mingw-w64-python2-keyring: for wheel.signatures')
for _arch in ${_architectures}; do
- cd "${srcdir}/python2-build-${_arch}"
- /usr/${_arch}/bin/python2.exe setup.py install --root="$pkgdir/" --prefix=\usr/${_arch} --optimize=1
- install -D -m644 LICENSE.txt "${pkgdir}/usr/${_arch}/share/licenses/${pkgname}/LICENSE.txt"
- mv "${pkgdir}/usr/${_arch}/bin/wheel.exe" "${pkgdir}/usr/${_arch}/bin/wheel2.exe"
- mv "${pkgdir}/usr/${_arch}/bin/wheel-script.py" "${pkgdir}/usr/${_arch}/bin/wheel2-script.py"
+ cd "${srcdir}/python3-build-${_arch}"
+ /usr/${_arch}/bin/python3.exe setup.py install --root="$pkgdir/" --prefix=\usr/${_arch} --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/${_arch}/share/licenses/${pkgname}/LICENSE.txt"
done
- mv "${pkgdir}/usr/i686-w64-mingw32/bin/wheel.exe.manifest" "${pkgdir}/usr/i686-w64-mingw32/bin/wheel2.exe.manifest"
}