summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--bpo-11566.patch10
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e29223e7b44c..0802797527f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-python35-bin
pkgdesc = Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)
pkgver = 3.5.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.python.org/
arch = any
license = PSF
@@ -18,10 +18,12 @@ pkgbase = mingw-w64-python35-bin
source = https://www.python.org/ftp/python/3.5.4/python-3.5.4-embed-amd64.zip
source = https://www.python.org/ftp/python/3.5.4/Python-3.5.4.tgz
source = wine-python.sh
+ source = bpo-11566.patch
sha256sums = 61ca8e983be03a85beadd74da9dd1d38d9cfb23e298b9561482a7f531d48a7b9
sha256sums = 4b649c6ec5b2abfb9fc0f6a6d0dcbd9855d8b06ea03637fd142175822cf842f9
sha256sums = 6ed87a8b6c758cc3299a8b433e8a9a9122054ad5bc8aad43299cff3a53d8ca44
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mingw-w64-python35-bin
diff --git a/PKGBUILD b/PKGBUILD
index bdb729f7d6de..1221e4aa405e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-python35-bin
pkgver=3.5.4
_pybasever=35
-pkgrel=2
+pkgrel=3
pkgdesc="Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)"
arch=('any')
license=('PSF')
@@ -13,16 +13,23 @@ options=('staticlibs' '!buildflags' '!strip')
source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win32.zip"
"https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-amd64.zip"
"https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tgz"
- wine-python.sh)
+ wine-python.sh bpo-11566.patch)
noextract=("python-${pkgver}-embed-win32.zip"
"python-${pkgver}-embed-amd64.zip")
sha256sums=('61ca8e983be03a85beadd74da9dd1d38d9cfb23e298b9561482a7f531d48a7b9'
'4b649c6ec5b2abfb9fc0f6a6d0dcbd9855d8b06ea03637fd142175822cf842f9'
'6ed87a8b6c758cc3299a8b433e8a9a9122054ad5bc8aad43299cff3a53d8ca44'
- SKIP)
+ SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare () {
+ cd "${srcdir}/Python-${pkgver}"
+ # https://bugs.python.org/issue11566
+ patch -p1 -i "${srcdir}"/bpo-11566.patch
+}
+
build() {
cd "${srcdir}/Python-${pkgver}"
for _arch in ${_architectures}; do
diff --git a/bpo-11566.patch b/bpo-11566.patch
new file mode 100644
index 000000000000..056f87ccd9c2
--- /dev/null
+++ b/bpo-11566.patch
@@ -0,0 +1,10 @@
+--- a/PC/pyconfig.h.orig 2018-10-31 18:10:31.305748749 +0100
++++ b/PC/pyconfig.h 2018-10-31 18:10:48.242416545 +0100
+@@ -282,7 +282,6 @@
+ #endif
+
+ #define COMPILER "[gcc]"
+-#define hypot _hypot
+ #define PY_LONG_LONG long long
+ #define PY_LLONG_MIN LLONG_MIN
+ #define PY_LLONG_MAX LLONG_MAX