summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Ensure-static-plugins-are-exported.patch4
-rw-r--r--0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch4
-rw-r--r--0003-Disable-d3d12-requiring-fxc.exe.patch4
-rw-r--r--[-rwxr-xr-x]PKGBUILD18
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
7 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd98e97a2c28..c455e2b5dae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.15.12+kde+r31
+ pkgver = 5.15.13+kde+r30
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -19,13 +19,13 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qtdeclarative#commit=792a55bb701d233116c3731c7a53ffdb8c67e407
+ source = git+https://invent.kde.org/qt/qt/qtdeclarative#commit=b99568135aa60de96ca2e121dc2e8d83fb1ca886
source = 0001-Ensure-static-plugins-are-exported.patch
source = 0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
source = 0003-Disable-d3d12-requiring-fxc.exe.patch
- sha256sums = SKIP
- sha256sums = bf3bf0817e05b54f8e09cc7d1ca6d048bdaf5288fd8c44e6f47d14d67d82a9ca
- sha256sums = cd888659520aa08abc677013be985c578b1b623d07616a3b2acaa680fa8b1000
- sha256sums = 883de3bb703214511c760c2cfa6cec796bc9d1b8197de944864c7a4a31277e40
+ sha256sums = 7ed5dd98f8123b7678d347ff6b55d7475a1af00b3f5d4d7476029c12a241df41
+ sha256sums = 4504b8402891188e8a7274489e241b886648079e61270b0a95e37473bf0970af
+ sha256sums = 996d4fa1c19d0fe14d10de09f5017e7194d21877611d407da9908888d345e3f0
+ sha256sums = c0cf74107f30d2a6d735aa5466a1f57c08ca0fa2f800765b8e684877271e9ddc
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Ensure-static-plugins-are-exported.patch b/0001-Ensure-static-plugins-are-exported.patch
index bc0741e9f93e..0b674b313793 100644
--- a/0001-Ensure-static-plugins-are-exported.patch
+++ b/0001-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From 236fa5209d3a1087c7791ad4b04a3ef543a07af6 Mon Sep 17 00:00:00 2001
+From 34b52604f546c15a1b44572a5b060ece60b9bbdb Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 1/3] Ensure static plugins are exported
@@ -19,5 +19,5 @@ index 4242143bca..bccb7b3146 100644
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
-2.43.0
+2.44.0
diff --git a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index c5a7d05383a1..5ee27b10ef48 100644
--- a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From 8138c7d1842d6377148e2bb093bc6dca3103be59 Mon Sep 17 00:00:00 2001
+From a410a84f1c73fc15e80bad994a975271e2ec58ee Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 2/3] Prevent exporting QML parser symbols on static build
@@ -33,5 +33,5 @@ index bf8155c6ec..2bfa230bcc 100644
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
-2.43.0
+2.44.0
diff --git a/0003-Disable-d3d12-requiring-fxc.exe.patch b/0003-Disable-d3d12-requiring-fxc.exe.patch
index 85e4dfc3efd3..ce0e917fa923 100644
--- a/0003-Disable-d3d12-requiring-fxc.exe.patch
+++ b/0003-Disable-d3d12-requiring-fxc.exe.patch
@@ -1,4 +1,4 @@
-From 33d0d1191a372197f9afea3264a812f5332030e6 Mon Sep 17 00:00:00 2001
+From 34f59d18593dbb822f7daf692c4f16c2109ce511 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 20 Nov 2020 18:32:31 +0100
Subject: [PATCH 3/3] Disable d3d12 requiring fxc.exe
@@ -29,5 +29,5 @@ index 39c0c0815c..9cc521a191 100644
qtConfig(openvg): SUBDIRS += openvg
--
-2.43.0
+2.44.0
diff --git a/PKGBUILD b/PKGBUILD
index b10b2b3ecf82..eb9b381eb8fa 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,16 +14,16 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-vulkan-headers' 'mingw-w64-pkg-config' 'python')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=792a55bb701d233116c3731c7a53ffdb8c67e407
+_commit=b99568135aa60de96ca2e121dc2e8d83fb1ca886
_basever=${pkgver%%+*}
-pkgver+=+kde+r31
+pkgver+=+kde+r30
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
@@ -33,10 +33,10 @@ source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Ensure-static-plugins-are-exported.patch'
'0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch'
'0003-Disable-d3d12-requiring-fxc.exe.patch')
-sha256sums=('SKIP'
- 'bf3bf0817e05b54f8e09cc7d1ca6d048bdaf5288fd8c44e6f47d14d67d82a9ca'
- 'cd888659520aa08abc677013be985c578b1b623d07616a3b2acaa680fa8b1000'
- '883de3bb703214511c760c2cfa6cec796bc9d1b8197de944864c7a4a31277e40')
+sha256sums=('7ed5dd98f8123b7678d347ff6b55d7475a1af00b3f5d4d7476029c12a241df41'
+ '4504b8402891188e8a7274489e241b886648079e61270b0a95e37473bf0970af'
+ '996d4fa1c19d0fe14d10de09f5017e7194d21877611d407da9908888d345e3f0'
+ 'c0cf74107f30d2a6d735aa5466a1f57c08ca0fa2f800765b8e684877271e9ddc')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -64,7 +64,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -77,7 +77,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 5fe2f8d4bbac..7240673f6e7f 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -6,7 +6,7 @@
# Contributor: ohmyarch
% end
\
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index cc2ecb636e3a..751f7483472d 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-SKIP
+7ed5dd98f8123b7678d347ff6b55d7475a1af00b3f5d4d7476029c12a241df41