summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD63
2 files changed, 33 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f2fad47ce7b..3c787f5adcb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = mingw-w64-winpthreads-git
pkgdesc = MinGW-w64 winpthreads library (git version)
- pkgver = 11.0.0.r643.g57f796c
+ pkgver = 11.0.0.r662.g14315e6
pkgrel = 1
url = http://mingw-w64.sourceforge.net
arch = any
- license = custom
+ license = MIT
makedepends = mingw-w64-gcc
makedepends = mingw-w64-binutils
makedepends = mingw-w64-crt
@@ -13,7 +13,6 @@ pkgbase = mingw-w64-winpthreads-git
options = staticlibs
options = !strip
options = !buildflags
- options = !emptydirs
source = git+https://git.code.sf.net/p/mingw-w64/mingw-w64
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 20b37e1016a4..adba9f487136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
-# Maintainer: bemxio <bemxiov@protonmail.com>
-# Contributor: Felix Yan <felixonmars@archlinux.org>
-# Contributor: pingplug <aur@pingplug.me>
+# Maintainer: bemxio <bemxiov at protonmail dot com>
+# Contributor: Felix Yan <felixonmars at archlinux dot org>
+# Contributor: pingplug <aur at pingplug dot me>
pkgname=mingw-w64-winpthreads-git
pkgdesc="MinGW-w64 winpthreads library (git version)"
_targets="i686-w64-mingw32 x86_64-w64-mingw32"
-pkgver=11.0.0.r643.g57f796c
+pkgver=11.0.0.r662.g14315e6
pkgrel=1
arch=(any)
url="http://mingw-w64.sourceforge.net"
-license=("custom")
+license=("MIT")
-#depends=()
makedepends=(mingw-w64-gcc mingw-w64-binutils mingw-w64-crt)
provides=(mingw-w64-winpthreads)
@@ -24,41 +23,41 @@ conflicts=(mingw-w64-winpthreads)
source=("git+https://git.code.sf.net/p/mingw-w64/mingw-w64")
md5sums=("SKIP")
-options=("staticlibs" "!strip" "!buildflags" "!emptydirs")
+options=("staticlibs" "!strip" "!buildflags")
pkgver() {
- # move to the source directory
- cd "${srcdir}/mingw-w64"
+ # move to the source directory
+ cd mingw-w64
- # use the most recent annotated tag reachable from the last commit
- git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ # use the most recent annotated tag reachable from the last commit
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- for _target in ${_targets}; do
- # make a build directory and move into it
- mkdir -p "${srcdir}/winpthreads-build-${_target}" && cd "${srcdir}/winpthreads-build-${_target}"
-
- # configure the build
- "${srcdir}/mingw-w64/mingw-w64-libraries/winpthreads/configure" \
- --prefix="/usr/${_target}" \
- --host="${_target}" \
- --enable-static --enable-shared
-
- # build the library
- make
- done
+ for _target in ${_targets}; do
+ # make a build directory and move into it
+ mkdir -p "winpthreads-build-${_target}" && cd "winpthreads-build-${_target}"
+
+ # configure the build
+ "${srcdir}/mingw-w64/mingw-w64-libraries/winpthreads/configure" \
+ --prefix="/usr/${_target}" \
+ --host="${_target}" \
+ --enable-static --enable-shared
+
+ # build the library
+ make
+ done
}
package() {
- for _target in ${_targets}; do
- # move to the build directory
- cd "${srcdir}/winpthreads-build-${_target}"
+ for _target in ${_targets}; do
+ # move to the build directory
+ cd "winpthreads-build-${_target}"
- # install the library
- make DESTDIR="${pkgdir}" install
+ # install the library
+ make DESTDIR="${pkgdir}" install
- # strip unneeded symbols from the DLLs
- "${_target}-strip" --strip-unneeded "${pkgdir}/usr/${_target}/bin"/*.dll
- done
+ # strip unneeded symbols from the DLLs
+ "${_target}-strip" --strip-unneeded "${pkgdir}/usr/${_target}/bin"/*.dll
+ done
}