summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27f4fe13842d..480f0f6ef095 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = miniaturo-git
pkgdesc = A raw image thumbnailer written in Rust. Drop-in replacement for raw-thumbnailer.
- pkgver = r24.44664f2
- pkgrel = 2
+ pkgver = 0.6.0.r0.g84dce0c
+ pkgrel = 1
url = https://github.com/dbrgn/miniaturo
arch = x86_64
arch = armv6h
@@ -14,7 +14,9 @@ pkgbase = miniaturo-git
depends = libopenraw
optdepends = raw-thumbnailer-entry: Thumbnailer configs for Nautilus/Thunar
provides = raw-thumbnailer
+ provides = miniaturo
conflicts = raw-thumbnailer
+ conflicts = miniaturo
options = !emptydirs
source = git+https://github.com/dbrgn/miniaturo
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c46688337576..9502c6f8702c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=miniaturo-git
_name=miniaturo
_binname=raw-thumbnailer
-pkgver=r24.44664f2
-pkgrel=2
+pkgver=0.6.0.r0.g84dce0c
+pkgrel=1
pkgdesc="A raw image thumbnailer written in Rust. Drop-in replacement for raw-thumbnailer."
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/dbrgn/miniaturo"
@@ -11,8 +11,8 @@ license=('GPL3')
depends=('libopenraw')
makedepends=('git' 'rust' 'cargo')
optdepends=('raw-thumbnailer-entry: Thumbnailer configs for Nautilus/Thunar')
-provides=('raw-thumbnailer')
-conflicts=('raw-thumbnailer')
+provides=('raw-thumbnailer' 'miniaturo')
+conflicts=('raw-thumbnailer' 'miniaturo')
options=(!emptydirs)
source=('git+https://github.com/dbrgn/miniaturo')
sha256sums=('SKIP')
@@ -36,7 +36,7 @@ package() {
pkgver() {
cd "$srcdir/$_name" || exit 1
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
# vim:set ts=2 sw=2 et: