summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--depend-lib-app.patch12
3 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a9992f9d0bd..2532764e4103 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Thu Mar 3 16:17:42 UTC 2016
+# Thu Mar 31 14:56:50 UTC 2016
pkgbase = minidjvu
pkgdesc = Highly efficient DjVu encoder for black-and-white images
pkgver = 0.8
- pkgrel = 4
+ pkgrel = 5
url = http://minidjvu.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
depends = libtiff
source = http://downloads.sourceforge.net/project/minidjvu/minidjvu/0.8/minidjvu-0.8.tar.gz
+ source = depend-lib-app.patch
md5sums = b354eb74d83c6e2d91aab2a6c2879ba7
+ md5sums = 6df7ee0413af8f86211f97e73eacc36e
pkgname = minidjvu
diff --git a/PKGBUILD b/PKGBUILD
index 8ba3eab16ffc..dad32bf024da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
# Maintainer: Markus Schaaf <markuschaaf@gmail.com>
pkgname=minidjvu
pkgver=0.8
-pkgrel=4
+pkgrel=5
pkgdesc='Highly efficient DjVu encoder for black-and-white images'
arch=(i686 x86_64)
url="http://$pkgname.sourceforge.net/"
license=(GPL)
depends=(libtiff)
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=(b354eb74d83c6e2d91aab2a6c2879ba7)
+source=(
+ "http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+ depend-lib-app.patch
+)
+md5sums=(
+ b354eb74d83c6e2d91aab2a6c2879ba7
+ 6df7ee0413af8f86211f97e73eacc36e
+)
+
+prepare() {
+ for p in *.patch ; do patch -Np0 < $p ; done
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libdir=/usr/lib
- sed -i -e 's#-9 \$(MANDIR)#-9 $(DESTDIR)$(MANDIR)#' Makefile
- make
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib
+ sed -i -e 's#-9 \$(MANDIR)#-9 $(DESTDIR)$(MANDIR)#' Makefile
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -d "$pkgdir"/usr/{bin,lib,share/man/man1}
- make DESTDIR="$pkgdir/" install
+ cd $pkgname-$pkgver
+ install -d "$pkgdir"/usr/{bin,lib,share/man/man1}
+ make DESTDIR="$pkgdir/" install
}
diff --git a/depend-lib-app.patch b/depend-lib-app.patch
new file mode 100644
index 000000000000..fcf6ff8f01fa
--- /dev/null
+++ b/depend-lib-app.patch
@@ -0,0 +1,12 @@
+diff -ur minidjvu-0.8-orig/Makefile.in minidjvu-0.8/Makefile.in
+--- minidjvu-0.8-orig/Makefile.in 2009-10-11 12:00:03.000000000 +0200
++++ minidjvu-0.8/Makefile.in 2016-03-31 16:17:31.735603674 +0200
+@@ -30,7 +30,7 @@
+ build-lib:
+ cd minidjvu && ${MAKE}
+
+-build-app:
++build-app: build-lib
+ cd src && ${MAKE}
+
+ build-po: