summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD83
2 files changed, 39 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c22de3682b6d..5637aa7864ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mintstick
- pkgdesc = A GUI to write .img or .iso files to a USB Key. It can also format them
- pkgver = 1.5.6
+ pkgdesc = A graphical tool that allows you to format USB sticks and create bootable USB sticks.
+ pkgver = 1.5.7
pkgrel = 1
url = http://packages.linuxmint.com/pool/main/m/mintstick
arch = any
@@ -26,7 +26,7 @@ pkgbase = mintstick
depends = util-linux
depends = xapp
conflicts = mintstick-git
- source = mintstick-1.5.6.tar.xz::http://packages.linuxmint.com/pool/main/m/mintstick/mintstick_1.5.6.tar.xz
- sha256sums = 8b23210847231b088e9f243cdd9f0ab6c5bc0d40fae9ffbb4e7a96ae251d4455
+ source = mintstick-1.5.7.tar.xz::http://packages.linuxmint.com/pool/main/m/mintstick/mintstick_1.5.7.tar.xz
+ sha256sums = 843a9a636d44f2f3a66f677b4e36387920df358114b4ceb659a59df1fd539c0c
pkgname = mintstick
diff --git a/PKGBUILD b/PKGBUILD
index 0cb4b62ae24e..2f21ece386b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,52 @@
# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
pkgname=mintstick
-pkgver=1.5.6
+pkgver=1.5.7
pkgrel=1
-pkgdesc='A GUI to write .img or .iso files to a USB Key. It can also format them'
+pkgdesc="A graphical tool that allows you to format USB sticks and create bootable USB sticks."
arch=('any')
url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
license=(GPL)
depends=(
- coreutils
- dbus-python
- desktop-file-utils
- dosfstools
- e2fsprogs
- exfatprogs
- glib2
- gtk3
- ntfs-3g
- parted
- polkit
- procps-ng
- python
- python-gobject
- python-pyparted
- python-xapp
- udisks2
- util-linux
- xapp
+ 'coreutils'
+ 'dbus-python'
+ 'desktop-file-utils'
+ 'dosfstools'
+ 'e2fsprogs'
+ 'exfatprogs'
+ 'glib2'
+ 'gtk3'
+ 'ntfs-3g'
+ 'parted'
+ 'polkit'
+ 'procps-ng'
+ 'python'
+ 'python-gobject'
+ 'python-pyparted'
+ 'python-xapp'
+ 'udisks2'
+ 'util-linux'
+ 'xapp'
)
makedepends=(
- gettext
+ 'gettext'
)
conflicts=(
- mintstick-git
+ 'mintstick-git'
)
source=("${pkgname}-${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
-sha256sums=('8b23210847231b088e9f243cdd9f0ab6c5bc0d40fae9ffbb4e7a96ae251d4455')
-
-prepare() {
- cd ${pkgname}
-
- ## File "install.sh" was not updated to match the new filenames. For now, this is added
- sed -i 's|org.linuxmint.im|com.linuxmint.mintstick|g' install.sh
- sed -i 's|mintstick.glade|mintstick.ui|g' install.sh
-
- ## https://wiki.archlinux.org/index.php/Arch_packaging_standards#Directories
- sed -i 's| /usr| "'$pkgdir'"/usr|g' install.sh
-
- ## Removing all instances of KDE4, since Linux Mint KDE Edition is no longer available
- rm -rf 'share/kde4'
-}
+sha256sums=('843a9a636d44f2f3a66f677b4e36387920df358114b4ceb659a59df1fd539c0c')
package() {
- cd ${pkgname}
-
- ## Creating the directories to copy the files
- install -d "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/share/applications"
- install -d "$pkgdir/usr/share/polkit-1/actions"
- cp -rp share/nemo "$pkgdir/usr/share"
-
- ## install.sh script is the one who contains all the installation process
- ./install.sh
+ cd "$pkgname"
+ install -Dm644 lib/* -t "$pkgdir/usr/lib/$pkgname/"
+ install -Dm644 "share/$pkgname"/* -t "$pkgdir/usr/share/$pkgname/"
+ install -Dm644 share/applications/* -t "$pkgdir/usr/share/applications/"
+ install -Dm644 share/polkit/* -t "$pkgdir/usr/share/polkit-1/actions/"
+ install -Dm755 "$pkgname" mint-iso-verify -t "$pkgdir/usr/bin/"
+ install -Dm644 share/nemo/actions/* -t "$pkgdir/usr/share/nemo/actions/"
+ install -Dm644 share/kde4/* -t "$pkgdir/usr/share/kde4/apps/solid/actions/"
+ cp -r share/icons "$pkgdir/usr/share/icons"
+ install -Dm755 bin/* -t "$pkgdir/usr/bin/"
+ install -Dm644 "debian/$pkgname.1" -t "$pkgdir/usr/share/man/man1/"
}