summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--append-CFLAGS.patch13
3 files changed, 5 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a69047631dc..87ae73801b38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mmc-utils-git
pkgdesc = Userspace tools for MMC/SD devices
- pkgver = r109.145c74a
+ pkgver = r128.f757f41
pkgrel = 1
epoch = 1
url = https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
@@ -14,8 +14,6 @@ pkgbase = mmc-utils-git
provides = mmc-utils
conflicts = mmc-utils
source = git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
- source = append-CFLAGS.patch
sha256sums = SKIP
- sha256sums = 0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc
pkgname = mmc-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index 3e38a4c38bc6..6e77560f061b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mmc-utils
pkgname=${_pkgname}-git
-pkgver=r109.145c74a
+pkgver=r128.f757f41
pkgrel=1
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
@@ -13,25 +13,14 @@ license=('GPL')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=(
- 'git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git'
- 'append-CFLAGS.patch'
-)
-sha256sums=(
- 'SKIP'
- '0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc'
-)
+source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_pkgname}"
- patch --forward --strip=1 --input="${srcdir}/append-CFLAGS.patch"
-}
-
build() {
cd "${_pkgname}"
make
@@ -39,6 +28,6 @@ build() {
package() {
cd "${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/man/man1/"
make DESTDIR="${pkgdir}" prefix=/usr install
- install -Dm644 man/mmc.1 "${pkgdir}/usr/share/man/man1/mmc.1"
}
diff --git a/append-CFLAGS.patch b/append-CFLAGS.patch
deleted file mode 100644
index e7903f168b41..000000000000
--- a/append-CFLAGS.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index d8d59a4..9b413f9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,7 @@
- CC ?= gcc
- GIT_VERSION := "$(shell git describe --abbrev=6 --always --tags)"
- AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
--CFLAGS ?= -g -O2 -DVERSION=\"$(GIT_VERSION)\"
-+CFLAGS += -g -O2 -DVERSION=\"$(GIT_VERSION)\"
- objects = \
- mmc.o \
- mmc_cmds.o \