summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--Makefile20
-rw-r--r--PKGBUILD38
-rw-r--r--mod_diary.install0
-rw-r--r--modules.mk8
5 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..053c987a9eba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mod_diary-git
+ pkgdesc = A simple and lightweight blog system for Apache HTTPD Server
+ pkgver = r25.0dfee1c
+ pkgrel = 1
+ url = https://github.com/hamano/apache-mod-diary
+ install = mod_diary.install
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ depends = apache
+ depends = apr
+ depends = discount
+ depends = clearsilver
+ depends = neon
+ provides = mod_diary
+ provides = mod_diary-git
+ source = apache-mod-diary::git+https://github.com/hamano/apache-mod-diary.git
+ source = Makefile
+ source = modules.mk
+ md5sums = SKIP
+ md5sums = f5e06242128e16fda2c34983dfa5a752
+ md5sums = 9e3a805eca1b815839a5ae22649f2c69
+
+pkgname = mod_diary-git
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..312b5a7f4692
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,20 @@
+builddir = .
+
+top_dir = /usr/lib/httpd
+
+top_srcdir = ${top_dir}
+top_builddir = ${top_dir}
+
+include ${top_builddir}/build/special.mk
+
+APXS = apxs
+APACHECTL = apachectl
+CFLAGS += -I/usr/include/ClearSilver
+
+all: local-shared-build diary-mkindex
+
+diary-mkindex:
+ $(CC) $(CFLAGS) diary-mkindex.c -lmarkdown -lneo_utl -lneo_cs -o $@
+
+clean:
+ -rm -f *.o *.lo *.slo *.la diary-mkindex
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71bb0f30b0f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+pkgname=mod_diary-git
+pkgver=r25.0dfee1c
+pkgrel=1
+pkgdesc="A simple and lightweight blog system for Apache HTTPD Server"
+license=('APACHE')
+arch=('i686' 'x86_64')
+url="https://github.com/hamano/apache-mod-diary"
+depends=('apache' 'apr' 'discount' 'clearsilver' 'neon')
+makedepends=('git')
+install=${pkgname/%-git/}.install
+source=('apache-mod-diary::git+https://github.com/hamano/apache-mod-diary.git'
+'Makefile' 'modules.mk')
+md5sums=('SKIP'
+'f5e06242128e16fda2c34983dfa5a752'
+'9e3a805eca1b815839a5ae22649f2c69')
+provides=('mod_diary' 'mod_diary-git')
+
+pkgver() {
+ cd "$srcdir"/apache-mod-diary
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"/apache-mod-diary
+ cp $srcdir/{Makefile,modules.mk} .
+ touch .deps
+ make top_dir=/usr/lib/httpd
+}
+
+package() {
+ cd "$srcdir"/apache-mod-diary
+ install -d "$pkgdir"/usr/{bin,lib/httpd/modules}
+ make top_dir=/usr/lib/httpd DESTDIR="$pkgdir" install
+ install --mode=755 diary-mkindex "$pkgdir"/usr/bin
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mod_diary.install b/mod_diary.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/mod_diary.install
diff --git a/modules.mk b/modules.mk
new file mode 100644
index 000000000000..e4427a3cddac
--- /dev/null
+++ b/modules.mk
@@ -0,0 +1,8 @@
+MOD_DIARY = mod_diary
+
+mod_diary.la: ${MOD_DIARY:=.slo}
+ $(SH_LINK) -rpath $(libexecdir) -module -avoid-version -lneo_cgi -lneo_utl -lneo_cs -lmarkdown ${MOD_DIARY:=.lo}
+
+DISTCLEAN_TARGETS = modules.mk
+
+shared = mod_diary.la