summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 317cc07b7518..c3a9293b1f95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,18 @@
pkgbase = modeltest-ng
- pkgdesc = A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models
+ pkgdesc = A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models. https://doi.org/10.1093/molbev/msz189
pkgver = 0.1.7
- pkgrel = 1
+ pkgrel = 6
url = https://github.com/ddarriba/modeltest
arch = x86_64
license = GPL3
- source = https://github.com/ddarriba/modeltest/files/6192913/modeltest-ng-0.1.7-static.tar.gz
- sha256sums = aab174ad96a420829ae02b0ed9802d008c7a67d5b48e4a7e7741d29b186a1097
+ makedepends = bison
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = flex
+ provides = modeltest-ng
+ conflicts = modeltest-ng-mpi
+ source = git+https://github.com/ddarriba/modeltest.git#tag=v0.1.7
+ sha256sums = SKIP
pkgname = modeltest-ng
diff --git a/PKGBUILD b/PKGBUILD
index 996d7ca3e682..270165010749 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,28 @@
pkgname=modeltest-ng
pkgver=0.1.7
-pkgrel=1
-pkgdesc="A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models"
+pkgrel=6
+pkgdesc="A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models. https://doi.org/10.1093/molbev/msz189"
url='https://github.com/ddarriba/modeltest'
arch=('x86_64')
+makedepends=('bison' 'git' 'cmake' 'make' 'flex')
license=('GPL3')
-source=("https://github.com/ddarriba/modeltest/files/6192913/modeltest-ng-${pkgver}-static.tar.gz")
-sha256sums=('aab174ad96a420829ae02b0ed9802d008c7a67d5b48e4a7e7741d29b186a1097')
-
-prepare() {
- cd "${srcdir}"
+source=("git+https://github.com/ddarriba/modeltest.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+provides=('modeltest-ng')
+conflicts=('modeltest-ng-mpi')
+prepare(){
+ cd ${srcdir}/modeltest
+ git submodule update --init --recursive
+}
+build(){
+ cd ${srcdir}/modeltest/
+ mkdir build && cd build
+ cmake ..
+ make
}
package() {
install -dm755 "${pkgdir}"/usr/bin
- install -Dm755 "${srcdir}/modeltest-ng-static" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/modeltest/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}