summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a916d14a960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = modeltest-ng-mpi
+ pkgdesc = A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models. https://doi.org/10.1093/molbev/msz189
+ pkgver = 0.1.7
+ pkgrel = 7
+ url = https://github.com/ddarriba/modeltest
+ arch = x86_64
+ license = GPL3
+ makedepends = bison
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = flex
+ depends = openmpi
+ provides = modeltest-ng
+ conflicts = modeltest-ng
+ source = git+https://github.com/ddarriba/modeltest.git#tag=v0.1.7
+ sha256sums = SKIP
+
+pkgname = modeltest-ng-mpi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a503f9cd104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi ("malcology") <guoyizhang@malacology.net>
+# Contributor: Guoyi ("malcology") <guoyizhang@malacology.net>
+
+pkgname=modeltest-ng-mpi
+pkgver=0.1.7
+pkgrel=7
+pkgdesc="A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models. https://doi.org/10.1093/molbev/msz189"
+url='https://github.com/ddarriba/modeltest'
+arch=('x86_64')
+depends=('openmpi')
+makedepends=('bison' 'git' 'cmake' 'make' 'flex')
+license=('GPL3')
+source=("git+https://github.com/ddarriba/modeltest.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+provides=('modeltest-ng')
+conflicts=('modeltest-ng')
+prepare(){
+ cd ${srcdir}/modeltest
+ git submodule update --init --recursive
+}
+build(){
+ cd ${srcdir}/modeltest/
+ mkdir build && cd build
+ cmake -DUSE_MPI=ON ..
+ make
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/bin
+ install -Dm755 "${srcdir}/modeltest/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}